summaryrefslogtreecommitdiff
path: root/src/perl/Makefile.am
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2001-07-29 09:17:53 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2001-07-29 09:17:53 +0000
commit6c2f9c685aaf4aa79c9ea3f29efe0c22aa0a98ee (patch)
tree0f6377555e2b9cdc881731fd06dc3723632150ac /src/perl/Makefile.am
parent2d5edb8c4d56f75f4dab93929072cc2699ec5ccd (diff)
downloadirssi-6c2f9c685aaf4aa79c9ea3f29efe0c22aa0a98ee.zip
--enable-perl* -> --with-perl*. Added a new libfe_perl which handles /SCRIPT
commands. /RUN -> /SCRIPT LOAD, /PERLFLUSH -> /SCRIPT FLUSH, /PERL -> /SCRIPT EXEC. Added /SCRIPT UNLOAD, /SCRIPT LIST. Lots of cleanups. filename_complete() has extra argument for "default directory" which is searched if no path is given when completing. git-svn-id: http://svn.irssi.org/repos/irssi/trunk@1680 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'src/perl/Makefile.am')
-rw-r--r--src/perl/Makefile.am49
1 files changed, 33 insertions, 16 deletions
diff --git a/src/perl/Makefile.am b/src/perl/Makefile.am
index 14071459..21e40f2e 100644
--- a/src/perl/Makefile.am
+++ b/src/perl/Makefile.am
@@ -2,29 +2,43 @@ LIBTOOL = $(PERL_LIBTOOL)
moduledir = $(libdir)/irssi/modules
-module_LTLIBRARIES = $(perl_module_lib)
-noinst_LTLIBRARIES = $(perl_static_lib)
+module_LTLIBRARIES = $(perl_module_lib) $(perl_module_fe_lib)
+noinst_LTLIBRARIES = $(perl_static_lib) $(perl_static_fe_lib)
EXTRA_LTLIBRARIES = \
- libperl_core.la \
- libperl_static.la
+ libperl_core.la libfe_perl.la \
+ libperl_core_static.la libfe_perl_static.la
libperl_core_la_LDFLAGS = -avoid-version -rpath $(moduledir)
+libfe_perl_la_LDFLAGS = -avoid-version -rpath $(moduledir)
-perl.c: perl-signals-list.h
+perl-core.c: perl-signals-list.h irssi-core.pl.h
INCLUDES = $(GLIB_CFLAGS) \
-DSCRIPTDIR=\""$(libdir)/irssi/scripts"\" \
-DPERL_LIB_DIR=\""$(PERL_LIB_DIR)"\" \
$(PERL_CFLAGS) \
-I$(top_srcdir)/src \
- -I$(top_srcdir)/src/core
+ -I$(top_srcdir)/src/core \
+ -I$(top_srcdir)/src/fe-common/core
perl_sources = \
- perl.c \
+ perl-core.c \
perl-common.c \
perl-signals.c \
+ perl-sources.c \
xsinit.c
+perl_fe_sources = \
+ module-formats.c \
+ perl-fe.c
+
+noinst_HEADERS = \
+ module.h \
+ perl-core.h \
+ perl-common.h \
+ perl-signals.h \
+ perl-sources.h
+
libperl_core_la_DEPENDENCIES = .libs/libperl_orig.a .libs/DynaLoader.a
.libs/libperl_orig.a:
@@ -39,12 +53,21 @@ libperl_core_la_DEPENDENCIES = .libs/libperl_orig.a .libs/DynaLoader.a
libperl_core_la_SOURCES = \
$(perl_sources)
-libperl_static_la_SOURCES = \
+libperl_core_static_la_SOURCES = \
$(perl_sources)
+libfe_perl_la_SOURCES = \
+ $(perl_fe_sources)
+
+libfe_perl_static_la_SOURCES = \
+ $(perl_fe_sources)
+
perl-signals-list.h: $(top_srcdir)/docs/signals.txt $(srcdir)/get-signals.pl
cat $(top_srcdir)/docs/signals.txt | $(perlpath) $(srcdir)/get-signals.pl > perl-signals-list.h
+irssi-core.pl.h: irssi-core.pl
+ $(top_srcdir)/file2header.sh $(srcdir)/irssi-core.pl irssi_core_code > irssi-core.pl.h
+
CORE_SOURCES = \
common/Irssi.xs \
common/Irssi.pm \
@@ -88,15 +111,11 @@ EXTRA_DIST = \
libperl_dynaloader.la \
libperl_orig.la \
get-signals.pl \
+ irssi-core.pl \
$(CORE_SOURCES) \
$(IRC_SOURCES) \
$(UI_SOURCES)
-noinst_HEADERS = \
- module.h \
- perl-common.h \
- perl-signals.h
-
all-local:
for dir in common irc ui; do \
cd $$dir && \
@@ -111,15 +130,13 @@ all-local:
cd ..; \
done
-# FIXME: remove after .99: the libfe_perl must not be used anymore
install-exec-local:
- -(rm -f $(moduledir)/libfe_perl.*)
for dir in common irc ui; do \
cd $$dir && $(MAKE) install && cd ..; \
done
clean-generic:
- rm -f common/Irssi.c irc/Irc.c ui/UI.c
+ rm -f common/Makefile irc/Makefile ui/Makefile
distclean: distclean-am
-(cd common && $(MAKE) realclean && rm -f Makefile.PL)