summaryrefslogtreecommitdiff
path: root/src/perl/Makefile.am
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2001-11-05 14:48:03 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2001-11-05 14:48:03 +0000
commit6a82e806b4d8ae146295c5b3d8fe4986f8ff747e (patch)
treee389a05d390b3b80114e8432707103e2ac6d8e18 /src/perl/Makefile.am
parenta6e9d7dfb798cf4624b0274c68fa11fcb64e58c5 (diff)
downloadirssi-6a82e806b4d8ae146295c5b3d8fe4986f8ff747e.zip
Moved $(GLIB_CFLAGS) after -I includes, to make sure our own .h files get before possibly identically named headers in the glib's include directory.
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@1975 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'src/perl/Makefile.am')
-rw-r--r--src/perl/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/src/perl/Makefile.am b/src/perl/Makefile.am
index 220397d6..739da6f4 100644
--- a/src/perl/Makefile.am
+++ b/src/perl/Makefile.am
@@ -13,14 +13,15 @@ libfe_perl_la_LDFLAGS = -avoid-version -rpath $(moduledir)
perl-core.c: perl-signals-list.h irssi-core.pl.h
-INCLUDES = $(GLIB_CFLAGS) \
+INCLUDES = \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/src/core \
+ -I$(top_srcdir)/src/fe-common/core \
+ $(GLIB_CFLAGS) \
-DSCRIPTDIR=\""$(libdir)/irssi/scripts"\" \
-DPERL_USE_LIB=\""$(PERL_USE_LIB)"\" \
-DPERL_STATIC_LIBS=$(PERL_STATIC_LIBS) \
- $(PERL_CFLAGS) \
- -I$(top_srcdir)/src \
- -I$(top_srcdir)/src/core \
- -I$(top_srcdir)/src/fe-common/core
+ $(PERL_CFLAGS)
perl_sources = \
perl-core.c \