summaryrefslogtreecommitdiff
path: root/src/irc/dcc/Makefile.am
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2001-01-18 02:30:59 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2001-01-18 02:30:59 +0000
commitce6e5a12f92f5375da6bcf499be666210856dbf3 (patch)
tree172f342986f4f86aaf1ccf7f99331c642ef617f5 /src/irc/dcc/Makefile.am
parentbabf7c77ac9344c8b12ca2ce87096e7ed079b687 (diff)
downloadirssi-ce6e5a12f92f5375da6bcf499be666210856dbf3.zip
DCC cleanups - half rewrite. New features: file names with spaces work
properly, you can have multiple dcc chats with same people (or more useful, same nick in different ircnets), /DCC CHAT|GET|RESUME with no arguments accepts the last request, notifies if dcc request was sent to channel, warns about connecting to lowports, /SET dcc_autoget_lowports specifies if autogetting should work with lowports, complains of invalid dcc ctcps instead of ignoring. And fixed /SET dcc_autorename OFF which didn't work before. git-svn-id: http://svn.irssi.org/repos/irssi/trunk@1135 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'src/irc/dcc/Makefile.am')
-rw-r--r--src/irc/dcc/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/irc/dcc/Makefile.am b/src/irc/dcc/Makefile.am
index 91250034..d8274173 100644
--- a/src/irc/dcc/Makefile.am
+++ b/src/irc/dcc/Makefile.am
@@ -9,8 +9,13 @@ INCLUDES = $(GLIB_CFLAGS) \
libirc_dcc_la_SOURCES = \
dcc.c \
dcc-chat.c \
- dcc-files.c
+ dcc-get.c \
+ dcc-send.c \
+ dcc-resume.c \
+ dcc-autoget.c
noinst_HEADERS = \
dcc.h \
+ dcc-chat.h \
+ dcc-get.h \
module.h