summaryrefslogtreecommitdiff
path: root/src/fe-fuzz/Makefile.am
diff options
context:
space:
mode:
authorJoseph Bisch <joseph.bisch@gmail.com>2017-01-07 20:01:07 -0500
committerJoseph Bisch <joseph.bisch@gmail.com>2017-01-07 20:01:07 -0500
commitcf4690725667211bc8a8998e362c6bda24dd7528 (patch)
treeecd89755df29366a40806865a7910954a5b49e9f /src/fe-fuzz/Makefile.am
parent7c09b72a26884bcd9711f39e2730ab09e658eec1 (diff)
downloadirssi-cf4690725667211bc8a8998e362c6bda24dd7528.zip
Add frontend for fuzzing
Use the following configure command: $ ./configure --with-fuzzer --with-fuzzer-lib=/path/to/libFuzzer.a \ CC=clang CXX=clang++ Places an irssi-fuzz in src/fe-fuzz/ after build. Also can specify SANFLAGS to override the chosen sanitizer flags (defaults to "-g -fsanitize=address -fsanitize-coverage=trace-pc-guard").
Diffstat (limited to 'src/fe-fuzz/Makefile.am')
-rw-r--r--src/fe-fuzz/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/fe-fuzz/Makefile.am b/src/fe-fuzz/Makefile.am
new file mode 100644
index 00000000..2ecf4a85
--- /dev/null
+++ b/src/fe-fuzz/Makefile.am
@@ -0,0 +1,25 @@
+bin_PROGRAMS = irssi-fuzz
+
+# Force link with clang++ for libfuzzer support
+CCLD=clang++ $(CXXFLAGS)
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/src/core/ \
+ -I$(top_srcdir)/src/irc/core/ \
+ -I$(top_srcdir)/src/fe-common/core/ \
+ $(GLIB_CFLAGS)
+
+irssi_fuzz_DEPENDENCIES = @COMMON_LIBS@
+
+irssi_fuzz_LDADD = \
+ @COMMON_LIBS@ \
+ @PROG_LIBS@ \
+ $(FUZZER_LIBS)
+
+irssi_fuzz_SOURCES = \
+ irssi.c \
+ module-formats.c
+
+noinst_HEADERS = \
+ module-formats.h