summaryrefslogtreecommitdiff
path: root/src/fe-common/irc/Makefile.am
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2002-05-16 00:34:37 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2002-05-16 00:34:37 +0000
commitd346fbe1a9c6615c88dfacc420f0256b5a751440 (patch)
tree2afa5956d03f670310bb45e019c2259b2ba46a10 /src/fe-common/irc/Makefile.am
parentee80e7601a0e664525cfc1f47bf90f30c93512d4 (diff)
downloadirssi-d346fbe1a9c6615c88dfacc420f0256b5a751440.zip
Better !channel support - window items now have "visual_name" and channels
and queries also have "name". Normally they're identical but with !channels the visible_name contains the short !channel name, while name contains full !ABCDEchannel name. The visible_name should be used whenever displaying the channel name, or as printtext()'s target. So, this breaks a few scripts in !channels, they need to be modified to use $channel->{visible_name} instead. Also /LAYOUT SAVE should finally work properly with !channels. git-svn-id: http://svn.irssi.org/repos/irssi/trunk@2797 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'src/fe-common/irc/Makefile.am')
-rw-r--r--src/fe-common/irc/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/fe-common/irc/Makefile.am b/src/fe-common/irc/Makefile.am
index 8e1b1501..d633d247 100644
--- a/src/fe-common/irc/Makefile.am
+++ b/src/fe-common/irc/Makefile.am
@@ -14,7 +14,6 @@ INCLUDES = \
real_sources = \
fe-irc-channels.c \
fe-irc-commands.c \
- fe-irc-layout.c \
fe-irc-messages.c \
fe-irc-queries.c \
fe-irc-server.c \
@@ -33,6 +32,7 @@ libfe_common_irc_a_SOURCES = \
irc-modules.c
noinst_HEADERS = \
+ fe-irc-server.h \
module.h \
module-formats.h