summaryrefslogtreecommitdiff
path: root/src/core/Makefile.am
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2000-04-26 08:03:38 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2000-04-26 08:03:38 +0000
commitc95034c6de1bf72536595e1e3431d8ec64b9880e (patch)
treee51aa4528257ed8aa9d53640649519f299aaf0c7 /src/core/Makefile.am
parentd01b094151705d433bc43cae9eeb304e6f110a17 (diff)
downloadirssi-c95034c6de1bf72536595e1e3431d8ec64b9880e.zip
..adding new files..
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@171 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'src/core/Makefile.am')
-rw-r--r--src/core/Makefile.am59
1 files changed, 59 insertions, 0 deletions
diff --git a/src/core/Makefile.am b/src/core/Makefile.am
new file mode 100644
index 00000000..c7cd93b5
--- /dev/null
+++ b/src/core/Makefile.am
@@ -0,0 +1,59 @@
+noinst_LTLIBRARIES = libcore.la
+
+INCLUDES = \
+ $(GLIB_CFLAGS) \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/src/core
+
+if BUILD_MEMDEBUG
+memdebug_src=memdebug.c
+else
+memdebug_src=
+endif
+
+libcore_la_SOURCES = \
+ args.c \
+ commands.c \
+ core.c \
+ levels.c \
+ line-split.c \
+ log.c \
+ $(memdebug_src) \
+ misc.c \
+ modules.c \
+ net-disconnect.c \
+ net-nonblock.c \
+ network.c \
+ pidwait.c \
+ rawlog.c \
+ server.c \
+ server-redirect.c \
+ settings.c \
+ signals.c \
+ special-vars.c
+
+noinst_HEADERS = \
+ args.h \
+ commands.h \
+ core.h \
+ levels.h \
+ line-split.h \
+ log.h \
+ memdebug.h \
+ misc.h \
+ module.h \
+ modules.h \
+ net-disconnect.h \
+ net-nonblock.h \
+ network.h \
+ pidwait.h \
+ rawlog.h \
+ server.h \
+ server-redirect.h \
+ settings.h \
+ signals.h \
+ special-vars.h
+
+EXTRA_DIST = \
+ memdebug.c