summaryrefslogtreecommitdiff
path: root/src/core/Makefile.am
diff options
context:
space:
mode:
authorailin-nemui <ailin-nemui@users.noreply.github.com>2017-02-16 22:48:13 +0100
committerailin-nemui <ailin-nemui@users.noreply.github.com>2017-06-04 00:52:53 +0200
commit79bbca4644cad7f2dee89c7ac6b8f9acc2c8b427 (patch)
tree86b908491ac1ab00cb079526b1f32a5d294d75a6 /src/core/Makefile.am
parent31b9d115b065570020ce9be1a1d8cd49212f70a9 (diff)
downloadirssi-79bbca4644cad7f2dee89c7ac6b8f9acc2c8b427.zip
Refactor regex and implement UTF8 mode for GRegex
- with non-unicode byte to Private Use Area A mapping - move all ifdefs to iregex.h file only
Diffstat (limited to 'src/core/Makefile.am')
-rw-r--r--src/core/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/core/Makefile.am b/src/core/Makefile.am
index 10bd035a..91daba3f 100644
--- a/src/core/Makefile.am
+++ b/src/core/Makefile.am
@@ -7,6 +7,12 @@ AM_CPPFLAGS = \
-DSYSCONFDIR=\""$(sysconfdir)"\" \
-DMODULEDIR=\""$(libdir)/irssi/modules"\"
+if USE_GREGEX
+regex_impl=iregex-gregex.c
+else
+regex_impl=iregex-regexh.c
+endif
+
libcore_a_SOURCES = \
args.c \
channels.c \
@@ -45,6 +51,7 @@ libcore_a_SOURCES = \
signals.c \
special-vars.c \
utf8.c \
+ $(regex_impl) \
wcwidth.c \
tls.c \
write-buffer.c
@@ -97,6 +104,7 @@ pkginc_core_HEADERS = \
signals.h \
special-vars.h \
utf8.h \
+ iregex.h \
window-item-def.h \
tls.h \
write-buffer.h \