summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2001-08-09 11:08:24 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2001-08-09 11:08:24 +0000
commit396ece99b674c1eb673af5be0160aae1568437d6 (patch)
treeee646215a7643d2e988bf6758ac788d988d8762d /debian
parent93382190e592128ad200291cd82402522ace39b6 (diff)
downloadirssi-396ece99b674c1eb673af5be0160aae1568437d6.zip
updates
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@1736 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules11
1 files changed, 2 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index 09ef4f81..12ed6a9f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,22 +11,15 @@ TMP=`pwd`/debian/irssi-text
configure: configure-stamp
configure-stamp:
dh_testdir
- if grep -q in6_addr /usr/include/netinet/in.h ; then \
./configure --prefix=/usr --exec-prefix=/usr --sysconf=/etc \
--without-servertest --enable-ipv6 --with-bot --with-proxy \
- --enable-perl=yes ; else \
- ./configure --prefix=/usr --exec-prefix=/usr --sysconf=/etc \
- --without-servertest --disable-ipv6 --with-bot --with-proxy \
- --enable-perl=yes ; fi
+ --enable-perl=yes --with-perl-lib=vendor
touch configure-stamp
build: configure-stamp build-stamp
build-stamp:
dh_testdir
- if test -z "`perl -v|grep '5\.0'`"; then \
- PERL_MM_OPT=INSTALLDIRS=vendor \
- $(MAKE) CFLAGS="-O2 -g -Wall" PERL_LIB_DIR= ; else \
- $(MAKE) CFLAGS="-O2 -g -Wall" PERL_LIB_DIR= ; fi
+ $(MAKE) CFLAGS="-O2 -g -Wall"
touch build-stamp
clean: