summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2001-03-28 21:23:13 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2001-03-28 21:23:13 +0000
commitfeab6175dc5e11c52b667cff4856131f61029f36 (patch)
tree13dad2d399033b383f2086d304b155fc50f5cff8 /configure.in
parent857664bb437f2278014b5d4a42fefee23219c50f (diff)
downloadirssi-feab6175dc5e11c52b667cff4856131f61029f36.zip
don't use which - cygwin doesn't have it
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@1428 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 10 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index 58b07111..f6efa958 100644
--- a/configure.in
+++ b/configure.in
@@ -130,18 +130,13 @@ AC_ARG_ENABLE(perl,
fi,
want_perl=yes)
-AC_ARG_WITH(servertest,
-[ --with-servertest Build servertest],
- if test x$withval = xyes; then
- want_servertest=yes
- else
- if test "x$withval" = xno; then
- want_servertest=no
- else
- want_servertest=yes
- fi
+AC_ARG_WITH(tests,
+[ --with-tests Run all the tests],
+ if test x$withval != xno; then
+ TEST_DIR=test
fi,
- want_servertest=no)
+ TEST_DIR=)
+AC_SUBST(TEST_DIR)
AC_ARG_ENABLE(curses-windows,
[ --enable-curses-windows Use curses windows],
@@ -314,10 +309,10 @@ if test "x$GLIB_DIR" = "x"; then
glib_file=glib-1.2.9.tar.gz
dlcmd=
- if test -f "`which ncftpget`"; then
+ if [ "x`ncftpget 2>/dev/null|grep -i ncftp`" != "x" ]; then
dlcmd="ncftpget ftp://ftp.gtk.org/pub/gtk/v1.2/$glib_file"
fi
- if test -f "`which wget`"; then
+ if [ "x`wget 2>/dev/null|grep -i wget`" != "x" ]; then
dlcmd="wget http://irssi.org/files/$glib_file"
fi
if test "x$dlcmd" != "x"; then
@@ -586,7 +581,7 @@ AM_CONDITIONAL(BUILD_TEXTUI, test "$want_textui" = "yes")
AM_CONDITIONAL(BUILD_IRSSIBOT, test "$want_irssibot" = "yes")
AM_CONDITIONAL(BUILD_IRSSIPROXY, test "$want_irssiproxy" = "yes")
AM_CONDITIONAL(BUILD_PLUGINS, test "$want_plugins" = "yes")
-AM_CONDITIONAL(BUILD_SERVERTEST, test "$want_servertest" = "yes")
+AM_CONDITIONAL(BUILD_SERVERTEST, test "x$TEST_DIR" != "x")
AM_CONDITIONAL(HAVE_PERL, test "$want_perl" != "no")
AM_CONDITIONAL(HAVE_STATIC_PERL, test "$want_perl" = "static")
@@ -702,6 +697,7 @@ po/Makefile.in
intl/Makefile
src/Makefile
src/lib/Makefile
+src/lib/test/Makefile
src/core/Makefile
src/irc/Makefile
src/irc/core/Makefile