summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2002-08-26 23:58:59 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2002-08-26 23:58:59 +0000
commitfce48d905b051b47dfd1a4ea325a706390ff6e86 (patch)
tree527a184849894ae13e817b78d27113936721a21c /configure.in
parent8790f97869008c25fa14aa7321b1dfce3af4a64b (diff)
downloadirssi-fce48d905b051b47dfd1a4ea325a706390ff6e86.zip
moved ncurses/terminfo/etc. libs away from PROG_LIBS which should be list of
common libraries for all ui frontends.. git-svn-id: http://svn.irssi.org/repos/irssi/trunk@2899 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 6fedad44..ebd9289e 100644
--- a/configure.in
+++ b/configure.in
@@ -510,7 +510,7 @@ dnl **
if test "x$want_textui" = "xyes"; then
AC_CHECK_CURSES
- LIBS="$LIBS $CURSES_LIBS"
+ TEXTUI_LIBS="$CURSES_LIBS"
if test "x$has_curses" = "xtrue"; then
AC_CHECK_FUNC(use_default_colors, AC_DEFINE(HAVE_NCURSES_USE_DEFAULT_COLORS))
AC_CHECK_FUNC(idcok, AC_DEFINE(HAVE_CURSES_IDCOK))
@@ -521,19 +521,21 @@ if test "x$want_textui" = "xyes"; then
])
else
AC_CHECK_LIB(tinfo, setupterm, [
- LIBS="$LIBS -ltinfo"
+ TEXTUI_LIBS="-ltinfo"
want_terminfo=yes
], AC_CHECK_LIB(termlib, tgetent, [
- LIBS="$LIBS -ltermlib"
+ TEXTUI_LIBS="-ltermlib"
want_termcap=yes
], AC_CHECK_LIB(termcap, tgetent, [
- LIBS="$LIBS -ltermcap"
+ TEXTUI_LIBS="-ltermcap"
want_termcap=yes
], [
AC_ERROR(Terminfo/termcap not found - install ncurses-devel package)
want_textui=no
])))
fi
+ AC_SUBST(TEXTUI_LIBS)
+
if test "x$want_termcap" = "xyes"; then
AC_CHECK_FUNC(tparm,, need_tparm=yes)
else