summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2001-10-24 23:17:27 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2001-10-24 23:17:27 +0000
commitddf1b27c048d6cfa6e3733d3256634b66d6d4c25 (patch)
tree01a3e176ef436f109611fe8ed17f2851ef01bae4 /configure.in
parentbbd4b47306a58c65e63a898b291efd797758f034 (diff)
downloadirssi-ddf1b27c048d6cfa6e3733d3256634b66d6d4c25.zip
Added --with-perl-staticlib option to configure. If used, irssi's perl
libraries are compiled statically into irssi binary. git-svn-id: http://svn.irssi.org/repos/irssi/trunk@1914 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d80d83e8..37d05636 100644
--- a/configure.in
+++ b/configure.in
@@ -106,6 +106,21 @@ if test "x$prefix" != "xNONE"; then
perl_prefix_note=yes
fi
+AC_ARG_WITH(perl-staticlib,
+[ --with-perl-staticlib Specify that we want to link perl libraries
+ statically in irssi, default is no],
+ if test x$withval = xyes; then
+ want_staticperllib=yes
+ else
+ if test "x$withval" = xno; then
+ want_staticperllib=no
+ else
+ want_staticperllib=yes
+ fi
+ fi,
+ want_staticperllib=no)
+
+
AC_ARG_WITH(perl-lib,
[ --with-perl-lib=[site|vendor|DIR] Specify where to install the
Perl libraries for irssi, default is site],
@@ -583,6 +598,14 @@ if test "$want_perl" != "no"; then
PERL_LIBTOOL='$(SHELL) $(top_builddir)/libtool'
fi
+ if test "x$want_staticperllib" = "xyes"; then
+ PERL_MM_PARAMS="$PERL_MM_PARAMS LINKTYPE=static"
+ PERL_LINK_LIBS="$PERL_LINK_LIBS ../perl/common/blib/arch/auto/Irssi/Irssi.a ../perl/irc/blib/arch/auto/Irssi/Irc/Irc.a ../perl/ui/blib/arch/auto/Irssi/UI/UI.a ../perl/textui/blib/arch/auto/Irssi/TextUI/TextUI.a"
+ PERL_STATIC_LIBS=1
+ else
+ PERL_STATIC_LIBS=0
+ fi
+
# figure out the correct @INC path - we'll need to do this
# through MakeMaker since it's difficult to get it right
# otherwise.
@@ -607,6 +630,7 @@ if test "$want_perl" != "no"; then
AC_SUBST(PERL_USE_LIB)
AC_SUBST(PERL_MM_PARAMS)
+ AC_SUBST(PERL_STATIC_LIBS)
fi
fi