summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2001-01-04 18:35:26 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2001-01-04 18:35:26 +0000
commitd431bea4395035632d280cfa9b7250bf29fe40bc (patch)
treea645d37670bc6d23b02ee40cf74e47f994901973 /configure.in
parent596ef586b2fc0fa6760178faaccd5d70de5c6617 (diff)
downloadirssi-d431bea4395035632d280cfa9b7250bf29fe40bc.zip
Renamed libtool-static to libtool-shared. Generating it should now also
work properly with older libtool versions than 1.3.5. git-svn-id: http://svn.irssi.org/repos/irssi/trunk@1064 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 7 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index a9f80d86..b68bbb18 100644
--- a/configure.in
+++ b/configure.in
@@ -14,7 +14,7 @@ AM_PROG_LIBTOOL
dnl * ahem.. :) we don't want static libraries for modules
if test "x$lt_target" = "x"; then
- if "x$target" = "x"; then
+ if test "$target" = "NONE"; then
lt_target="$host"
else
lt_target="$target"
@@ -26,7 +26,10 @@ if test "x$enable_static" = "xno"; then
fi
${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
-$libtool_flags --disable-static --output=libtool-static --no-verify $ac_aux_dir/ltmain.sh $lt_target \
+$libtool_flags --disable-static --output=libtool-shared --no-verify $ac_aux_dir/ltmain.sh $lt_target \
+|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
+${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
+$libtool_flags --no-verify $ac_aux_dir/ltmain.sh $host \
|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
AC_CHECK_HEADERS(string.h stdlib.h unistd.h dirent.h sys/ioctl.h libintl.h)
@@ -448,11 +451,11 @@ if test "$want_perl" != "no"; then
PERL_LIBTOOL='$(SHELL) $(top_builddir)/libtool'
else
dnl * build dynamic library of perl module,
- dnl * use libtool-static to prevent creating of
+ dnl * use libtool-shared to prevent creating of
dnl * libperl.a
module_lib=libperl.la
static_lib=
- PERL_LIBTOOL='$(SHELL) $(top_builddir)/libtool-static'
+ PERL_LIBTOOL='$(SHELL) $(top_builddir)/libtool-shared'
fi
AC_SUBST(module_lib)
AC_SUBST(static_lib)