summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2000-11-26 09:23:35 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2000-11-26 09:23:35 +0000
commita392b41f2ff5f4d3417d28508ec1a8c8a013fce0 (patch)
tree4957caa1c3e62980c69e8e3dfe9eb31893b3011f /configure.in
parent079932c4054fa6dd435268c2945b97fe01aff579 (diff)
downloadirssi-a392b41f2ff5f4d3417d28508ec1a8c8a013fce0.zip
if libperl.a isn't found, check from /usr/lib .. it seems to be there
with perl 5.6 git-svn-id: http://svn.irssi.org/repos/irssi/trunk@885 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d5044a51..024c116a 100644
--- a/configure.in
+++ b/configure.in
@@ -307,6 +307,13 @@ if test "$want_perl" != "no"; then
if test "$want_perl" != "static"; then
dnl * find libperl.a so we could
LIBPERL_A=`echo $PERL_LDFLAGS|$perlpath -e 'foreach (split(/ /, <STDIN>)) { if (/^-L(.*)/ && -f $1."/libperl.a") { print $1."/libperl.a" } };'`
+
+ dnl * In perl 5.6, libperl.a seems to be in /usr/lib ..
+ dnl * I can't really figure out any good way to check this
+ dnl * but hopefully this works well enough :)
+ if test "x$LIBPERL_A" = "x" -a /usr/lib/libperl.a; then
+ LIBPERL_A="/usr/lib/perl.a"
+ fi
fi
dnl * Perl 5.004 and older use perl_xxx variables while