summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorEmanuele Giaquinta <exg@irssi.org>2007-06-17 22:54:00 +0000
committerexg <exg@dbcabf3a-b0e7-0310-adc4-f8d773084564>2007-06-17 22:54:00 +0000
commit92035b9fb6354091add11626314f712d6366beee (patch)
tree95dce7d29f092d4e5e40f7ec425a85f76d7d4bda /configure.in
parent5a433f43598e6f1cc0d57bcb07cd90150533881e (diff)
downloadirssi-92035b9fb6354091add11626314f712d6366beee.zip
Do not invoke pkg-config to check that openssl is present,
PKG_CHECK_MODULES does it for us. git-svn-id: http://svn.irssi.org/repos/irssi/trunk@4567 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index a89b285e..d0a8e4f8 100644
--- a/configure.in
+++ b/configure.in
@@ -338,8 +338,8 @@ LIBS="$LIBS $GLIB_LIBS"
have_openssl=no
if test "$enable_ssl" = "yes"; then
- if pkg-config --exists openssl; then
- PKG_CHECK_MODULES(SSL, openssl)
+ PKG_CHECK_MODULES(SSL, openssl, :, :)
+ if test "$SSL_LIBS"; then
CFLAGS="$CFLAGS $SSL_CFLAGS"
have_openssl=yes
else