summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2000-07-09 14:27:59 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2000-07-09 14:27:59 +0000
commit6c66f6963e09bcccd35fd30d6607c37bfcbeeec5 (patch)
treed3f2ea4e23e8b857d37eaa1e4207c173f68e7be5 /configure.in
parent885790d08a5b3f56b2d27a6cf983ee7de6131644 (diff)
downloadirssi-6c66f6963e09bcccd35fd30d6607c37bfcbeeec5.zip
Getting ready for 0.7.93..
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@448 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 4b8f738e..412d4584 100644
--- a/configure.in
+++ b/configure.in
@@ -215,6 +215,7 @@ if test "x$want_textui" = "xyes"; then
if test "$has_curses" != "true"; then
want_textui=no;
+ curses_error=yes
fi
else
has_curses=false
@@ -270,7 +271,7 @@ dnl ** (these could be made configurable)
CHAT_MODULES="irc"
irc_MODULES="dcc flood notifylist"
-if test "$build_modules" != ""; then
+if test "x$build_modules" != "x"; then
irc_MODULES="$irc_MODULES $build_modules"
fi
@@ -394,7 +395,11 @@ fi
echo
-echo "Building text frontend ..... : $want_textui"
+if test "$curses_error" != "xyes"; then
+ echo "Building text frontend ..... : $want_textui"
+else
+ echo "Building text frontend ..... : NO!! (Because curses was not found, specify the path to it with --with-curses=/dir)"
+fi
echo "Building irssi-bot ......... : $want_irssibot"
echo "Building with IPv6 support . : $want_ipv6"
echo "Building with Perl support . : $want_perl"