summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2000-12-27 16:27:46 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2000-12-27 16:27:46 +0000
commit64eed6e82b9027a1597b140bb1e5af09f821f9e7 (patch)
treed3df67439a9dd19c75fac62df187c58a2f4519f8 /configure.in
parenta676bd8155756bb3dad19f13897f4aee402cfc68 (diff)
downloadirssi-64eed6e82b9027a1597b140bb1e5af09f821f9e7.zip
"glib in irssi dir" fixes
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@1020 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 11 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 8feb2698..db244126 100644
--- a/configure.in
+++ b/configure.in
@@ -238,9 +238,19 @@ if test "x$GLIB_DIR" != "x"; then
dnl glib in irssi directory, use it
AC_MSG_RESULT([yes, using it])
+ dnl * we have to do this at this point so we know what libs gmodule needs
+ echo
+ echo "configuring GLib ..."
+ echo
+ cd $GLIB_DIR
+ ./configure
+ cd ..
+ echo
+
+ GLIB_LDEXTRA=`$GLIB_DIR/glib-config --libs gmodule|sed -e 's/-lglib//' -e 's/-lgmodule//' -e 's,-L/usr/local/lib ,,'|sed 's/ \+/ /g'`
full_glib_dir="`pwd`/$GLIB_DIR"
GLIB_CFLAGS="-I$full_glib_dir -I$full_glib_dir/gmodule"
- GLIB_LIBS="$full_glib_dir/.libs/libglib.a $full_glib_dir/gmodule/.libs/libgmodule.a"
+ GLIB_LIBS="$full_glib_dir/.libs/libglib.a $full_glib_dir/gmodule/.libs/libgmodule.a $GLIB_LDEXTRA"
AC_SUBST(GLIB_DIR)
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)
@@ -546,15 +556,6 @@ if test "x$want_perl" != "xno"; then
fi
fi
-if test "x$GLIB_DIR" != "x"; then
- echo
- echo "configuring GLib ..."
- echo
- cd $GLIB_DIR
- ./configure
- cd ..
-fi
-
echo
if test "x$curses_error" != "xyes"; then