summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2000-02-24 21:14:44 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2000-02-24 21:14:44 +0000
commit4eb989ccb15fa597615ec19591d273853b495034 (patch)
treef8ca69a9284d4358784f21c429f178443345c5d9 /configure.in
parent60ddcc4005540005973d53899bc9e09dd689e7a5 (diff)
downloadirssi-4eb989ccb15fa597615ec19591d273853b495034.zip
Updated perl support
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@128 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in44
1 files changed, 23 insertions, 21 deletions
diff --git a/configure.in b/configure.in
index b368be16..97e9c0fa 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
AC_INIT(src)
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(irssi, 0.7.26)
+AM_INIT_AUTOMAKE(irssi, 0.7.27)
AM_MAINTAINER_MODE
@@ -345,26 +345,28 @@ fi
AC_PATH_PROG(sedpath, sed)
if test "$want_perl" = yes; then
- AC_PATH_PROG(perlpath, perl)
- AC_MSG_CHECKING(for Perl compile flags)
- PERL_CFLAGS=`$perlpath -MExtUtils::Embed -e ccopts 2>/dev/null`
- if test "_$PERL_CFLAGS" = _ ; then
- AC_MSG_RESULT([not found, building without perl.])
- want_perl=no
- else
- PERL_LDFLAGS=`$perlpath -MExtUtils::Embed -e ldopts |$sedpath 's/-lgdbm //'`
- PERL_LDFLAGS=`echo $PERL_LDFLAGS |$sedpath 's/-ldb //'`
- PERL_LDFLAGS=`echo $PERL_LDFLAGS |$sedpath 's/-lndbm //'`
- if test "$system" = "Linux"; then
- PERL_LDFLAGS=`echo $PERL_LDFLAGS |$sedpath 's/-lnsl //'`
- PERL_LDFLAGS=`echo $PERL_LDFLAGS |$sedpath 's/-lposix //'`
- fi
- PERL_LDFLAGS=`echo $PERL_LDFLAGS |$sedpath 's/-lc //'`
- AC_MSG_RESULT(ok)
- AC_SUBST(PERL_CFLAGS)
- AC_SUBST(PERL_LDFLAGS)
- AC_DEFINE(HAVE_PERL)
- fi
+ AC_PATH_PROG(perlpath, perl)
+ AC_MSG_CHECKING(for Perl compile flags)
+
+ PERL_CFLAGS=`$perlpath -MExtUtils::Embed -e ccopts 2>/dev/null`
+ if test "x$PERL_CFLAGS" = "x"; then
+ AC_MSG_RESULT([not found, building without perl.])
+ want_perl=no
+ else
+ PERL_LDFLAGS=`$perlpath -MExtUtils::Embed -e ldopts |$sedpath 's/-lgdbm //'`
+ PERL_LDFLAGS=`echo $PERL_LDFLAGS |$sedpath 's/-ldb //'`
+ PERL_LDFLAGS=`echo $PERL_LDFLAGS |$sedpath 's/-lndbm //'`
+ if test "$system" = "Linux"; then
+ PERL_LDFLAGS=`echo $PERL_LDFLAGS |$sedpath 's/-lnsl //'`
+ PERL_LDFLAGS=`echo $PERL_LDFLAGS |$sedpath 's/-lposix //'`
+ fi
+ PERL_LDFLAGS=`echo $PERL_LDFLAGS |$sedpath 's/-lc //'`
+ AC_MSG_RESULT(ok)
+
+ AC_SUBST(PERL_CFLAGS)
+ AC_SUBST(PERL_LDFLAGS)
+ AC_DEFINE(HAVE_PERL)
+ fi
fi
dnl ** check what we want to build