summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorEmanuele Giaquinta <exg@irssi.org>2007-04-29 23:43:17 +0000
committerexg <exg@dbcabf3a-b0e7-0310-adc4-f8d773084564>2007-04-29 23:43:17 +0000
commit47117f1f5f4bf0e3b898d2818ccaa20b85db80eb (patch)
tree7a5037b27e853d9d5736ed2c9cbdb2607d337497 /configure.in
parentf866799bb0acc96bdfb5e4f08da9aa9efe16c4f2 (diff)
downloadirssi-47117f1f5f4bf0e3b898d2818ccaa20b85db80eb.zip
Enable large file support using AC_SYS_LARGEFILE to get the correct
options on AIX, bug #404. git-svn-id: http://svn.irssi.org/repos/irssi/trunk@4472 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 2 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 7f4523fa..c799d5b2 100644
--- a/configure.in
+++ b/configure.in
@@ -31,6 +31,8 @@ AC_CHECK_HEADERS(string.h stdlib.h unistd.h dirent.h sys/ioctl.h sys/resource.h)
# check posix headers..
AC_CHECK_HEADERS(sys/time.h sys/utsname.h regex.h)
+AC_SYS_LARGEFILE
+
AC_ARG_WITH(socks,
[ --with-socks Build with socks support],
if test x$withval = xyes; then
@@ -204,12 +206,6 @@ AC_ARG_WITH(perl,
fi,
want_perl=static)
-AC_ARG_WITH(file-offset-size,
-[ --with-file-offset-size=BITS Set size of file offsets. Usually 32 or 64.
- (default: 64 if available)],
- preferred_off_t_bits=$withval,
- preferred_off_t_bits=64)
-
AC_ARG_ENABLE(ipv6,
[ --enable-ipv6 Enable IPv6 support],
if test x$enableval = xyes; then
@@ -280,9 +276,6 @@ AC_DEFINE(socklen_t, int, Define to 'int' if <sys/socket.h> doesn't define.)
fi
AC_MSG_RESULT($irssi_cv_type_socklen_t)
-dnl * off_t checks, try to make it 64bit
-AC_DEFINE_UNQUOTED(_FILE_OFFSET_BITS, $preferred_off_t_bits)
-
AC_CHECK_SIZEOF(int)
AC_CHECK_SIZEOF(long)
AC_CHECK_SIZEOF(long long)