summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2002-11-17 14:18:11 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2002-11-17 14:18:11 +0000
commit3182ac0d01ac2af862a9889a9bfca266f5a3a5e3 (patch)
tree81504c00a2936fb89d94d1513192b9c1c556b67d /configure.in
parent0368fa6b5b0e176c31748b84ce84dfbaad009cd1 (diff)
downloadirssi-3182ac0d01ac2af862a9889a9bfca266f5a3a5e3.zip
A bit more playing with perl cflags.
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@3003 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 97c97802..f9e78dfd 100644
--- a/configure.in
+++ b/configure.in
@@ -554,7 +554,10 @@ if test "$want_perl" != "no"; then
dnl * complain about them. Normally there's only few options
dnl * that we want to keep:
dnl * -Ddefine -Uundef -I/path -fopt -mopt
- PERL_CFLAGS=`echo $PERL_CFLAGS | $perlpath -pe 's/^(.* )?-[^DUIfm][^ ]+/\1/g'`
+ PERL_CFLAGS=`echo $PERL_CFLAGS | $perlpath -pe 's/^(.* )?-[^DUIfm][^ ]+/\1/g; s/^(.* )?\+[^ ]+/\1/g'`
+
+ PERL_EXTRA_OPTS="CCCDLFLAGS=\"-fPIC\""
+ AC_SUBST(PERL_EXTRA_OPTS)
fi
if test -z "$PERL_CFLAGS"; then