summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2000-09-07 22:43:07 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2000-09-07 22:43:07 +0000
commit2d16538decbb7838161922ede6881a9b9de568f2 (patch)
tree5ec29ba8d44e859911ad380096206d5c01a54b64 /configure.in
parent17bb7faf2f21869ea6a3336a1ac38587ea675e8f (diff)
downloadirssi-2d16538decbb7838161922ede6881a9b9de568f2.zip
Moved the PL_perl_destruct_level check to configure script, it should
now work with Perl 5.6 too. git-svn-id: http://svn.irssi.org/repos/irssi/trunk@657 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 354cfb4b..e5ac155d 100644
--- a/configure.in
+++ b/configure.in
@@ -234,6 +234,13 @@ if test "$want_perl" = "yes"; then
else
PERL_LDFLAGS="`$perlpath -MExtUtils::Embed -e ldopts` "
+ dnl * Perl 5.004 and older use perl_xxx variables while
+ dnl * later use PL_perl_xxx variables ..
+ have_pl_perl=`$perlpath -e 'print $] < 5.005 ? "no" : "yes";'`
+ if test "x$have_pl_perl" = "xyes"; then
+ AC_DEFINE(HAVE_PL_PERL)
+ fi
+
dnl * dynaloader.a -> libperl_dynaloader.la
dynaloader=`echo $PERL_LDFLAGS | $sedpath 's/.* \([[^ ]]*\.a\).*/\1/'`
PERL_LDFLAGS=`echo $PERL_LDFLAGS | $sedpath 's/ [[^ ]]*\.a/ libperl_dynaloader.la/'`