summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2000-08-10 20:02:59 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2000-08-10 20:02:59 +0000
commit2ae366c997c44bc90b28c33b4389e31daea8d03c (patch)
tree5f59684f67b67e1bb87eb96f5cbd2040e9d5a41b /configure.in
parent92e0995223d4fd2ae567bad94605f5a475988f75 (diff)
downloadirssi-2ae366c997c44bc90b28c33b4389e31daea8d03c.zip
For curses fixes..
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@580 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 6 insertions, 18 deletions
diff --git a/configure.in b/configure.in
index 5cb79b08..ed79037f 100644
--- a/configure.in
+++ b/configure.in
@@ -27,21 +27,6 @@ AC_ARG_WITH(socks,
fi,
want_socks=no)
-AC_ARG_WITH(mysql,
-[ --with-mysql Build MySQL plugin],
- if test x$withval = xyes; then
- want_mysql=yes
- MYSQL_LIBS="-L/usr/lib/mysql -lmysqlclient"
- else
- if test "x$withval" = xno; then
- want_mysql=no
- else
- want_mysql=yes
- MYSQL_LIBS="-L$withval/lib/mysql -lmysqlclient"
- fi
- fi,
- want_mysql=no)
-
AC_ARG_WITH(textui,
[ --with-textui Build text frontend],
if test x$withval = xyes; then
@@ -214,6 +199,9 @@ if test "x$want_textui" = "xyes"; then
AC_CHECK_LIB(ncurses, resizeterm, [
AC_DEFINE(HAVE_CURSES_RESIZETERM)
],, $CURSES_LIBS)
+ AC_CHECK_LIB(ncurses, wresize, [
+ AC_DEFINE(HAVE_CURSES_WRESIZE)
+ ],, $CURSES_LIBS)
else
AC_CHECK_LIB(curses, idcok, [
AC_DEFINE(HAVE_CURSES_IDCOK)
@@ -221,6 +209,9 @@ if test "x$want_textui" = "xyes"; then
AC_CHECK_LIB(curses, resizeterm, [
AC_DEFINE(HAVE_CURSES_RESIZETERM)
],, $CURSES_LIBS)
+ AC_CHECK_LIB(curses, wresize, [
+ AC_DEFINE(HAVE_CURSES_WRESIZE)
+ ],, $CURSES_LIBS)
fi
if test "$has_curses" != "true"; then
@@ -268,11 +259,8 @@ AM_CONDITIONAL(BUILD_TEXTUI, test "$want_textui" = "yes")
AM_CONDITIONAL(BUILD_IRSSIBOT, test "$want_irssibot" = "yes")
AM_CONDITIONAL(BUILD_PLUGINS, test "$want_plugins" = "yes")
AM_CONDITIONAL(BUILD_SERVERTEST, test "$want_servertest" = "yes")
-AM_CONDITIONAL(HAVE_MYSQL, test "$want_mysql" = "yes")
AM_CONDITIONAL(HAVE_PERL, test "$want_perl" = "yes")
-AC_SUBST(MYSQL_LIBS)
-
dnl **
dnl ** Keep all the libraries here so each frontend doesn't need to
dnl ** keep track of them all