summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2004-01-19 19:09:56 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2004-01-19 19:09:56 +0000
commit25a38d83a35afd46d503df2fc32c507a44793dc8 (patch)
tree0066fbbe2de221555f84df7b5e49c1879a46a80a /configure.in
parentf239784fd0af42d1db1f62b242262e75e846ecc3 (diff)
downloadirssi-25a38d83a35afd46d503df2fc32c507a44793dc8.zip
glib fetching updates by Rafael Kitover
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@3208 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index c9c2db82..72d236cc 100644
--- a/configure.in
+++ b/configure.in
@@ -437,11 +437,14 @@ if test -z "$GLIB_DIR"; then
glib_file=glib-1.2.10.tar.gz
dlcmd=
- if test -n "`ncftpget 2>/dev/null|grep -i ncftp`"; then
- dlcmd="ncftpget ftp://ftp.gtk.org/pub/gtk/v1.2/$glib_file"
- fi
- if test -n "`wget 2>/dev/null|grep -i wget`"; then
- dlcmd="wget http://irssi.org/files/$glib_file"
+ if test -n "`wget --version 2>/dev/null|grep -i wget`"; then
+ dlcmd="wget -c ftp://ftp.gtk.org/pub/gtk/v1.2/$glib_file"
+ elif test -n "`ncftpget --version 2>/dev/null|grep -i ncftp`"; then
+ dlcmd="ncftpget -z ftp://ftp.gtk.org/pub/gtk/v1.2/$glib_file"
+ elif test -n "`lynx --version 2>/dev/null|grep -i lynx`"; then
+ dlcmd="lynx --source ftp://ftp.gtk.org/pub/gtk/v1.2/$glib_file > $glib_file"
+ elif test -n "`curl --version 2>/dev/null|grep -i curl`"; then
+ dlcmd="curl -C - ftp://ftp.gtk.org/pub/gtk/v1.2/$glib_file"
fi
if test -n "$dlcmd"; then
echo "*** I can download GLib for you now. If you don't want to, press CTRL-C now."