summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Leadbeater <dgl@dgl.cx>2014-07-06 21:51:22 +0100
committerDavid Leadbeater <dgl@dgl.cx>2014-07-06 21:51:22 +0100
commit85d9fa1922a5f408dd40f18287f01135dd826e4d (patch)
tree8cea8911c731d523c76658d0e70a57e6a5032b30 /configure.ac
parent7949e4c53f8bc8cb0b28f38b7a08db49a00f8b01 (diff)
downloadirssi-85d9fa1922a5f408dd40f18287f01135dd826e4d.zip
Fix compiler warning in IPv6 check
(This was why I saw a warning from the IPv4 code path, now fixed by 7949e4c).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 40171a03..29fee0bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -628,7 +628,7 @@ if test "x$want_ipv6" = "xyes"; then
#include <netinet/in.h>
#include <netdb.h>
#include <arpa/inet.h>],
- [struct in6_addr i;],
+ [struct in6_addr i = in6addr_any; return &i == &i;],
have_ipv6=yes,
)])
if test $have_ipv6 = yes; then