summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNei <ailin.nemui@gmail.com>2017-01-02 17:03:31 +0000
committerailin-nemui <ailin-nemui@users.noreply.github.com>2017-01-03 13:30:39 +0100
commit7a112e021724af582a06eed8f92fafb772438c13 (patch)
tree733934527ce98cb4c9ecdd7fb20001650fabcd53 /configure.ac
parent1b99299ed2af2ae459edbeb96f2a7b7886cc22c9 (diff)
parent01163710e71318c6c2fd3f797f6b878f92b7f97b (diff)
downloadirssi-7a112e021724af582a06eed8f92fafb772438c13.zip
Merge branch 'master' into 'security'
Sync to master See merge request !6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 18 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index bf87f5aa..53d65671 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,7 +21,7 @@ AC_PATH_PROG(perlpath, perl)
AC_CHECK_HEADERS(unistd.h dirent.h sys/ioctl.h sys/resource.h)
# check posix headers..
-AC_CHECK_HEADERS(sys/socket.h sys/time.h sys/utsname.h regex.h)
+AC_CHECK_HEADERS(sys/socket.h sys/time.h sys/utsname.h)
AC_SYS_LARGEFILE
@@ -144,6 +144,15 @@ AC_ARG_ENABLE(true-color,
fi,
want_truecolor=no)
+AC_ARG_ENABLE(gregex,
+[ --disable-gregex Build without GRegex (fall back to regex.h)],
+ if test x$enableval = xno ; then
+ want_gregex=no
+ else
+ want_gregex=yes
+ fi,
+ want_gregex=yes)
+
dnl **
dnl ** just some generic stuff...
dnl **
@@ -237,7 +246,7 @@ for try in 1 2; do
echo "*** trying without -lgmodule"
glib_modules=
fi
- AM_PATH_GLIB_2_0(2.16.0,,, $glib_modules)
+ AM_PATH_GLIB_2_0(2.28.0,,, $glib_modules)
if test "$GLIB_LIBS"; then
if test $glib_modules = gmodule; then
AC_DEFINE(HAVE_GMODULE)
@@ -534,6 +543,12 @@ else
want_truecolor=no
fi
+if test "x$want_gregex" = "xyes"; then
+ AC_DEFINE([USE_GREGEX], [], [use GRegex for regular expressions])
+else
+ want_gregex=no
+fi
+
AH_TEMPLATE(HAVE_GMODULE)
AH_TEMPLATE(HAVE_SOCKS_H, [misc..])
AH_TEMPLATE(HAVE_STATIC_PERL)
@@ -648,6 +663,7 @@ echo
echo "Building with 64bit DCC support .. : $offt_64bit"
echo "Building with true color support.. : $want_truecolor"
+echo "Building with GRegex ............. : $want_gregex"
echo
echo "If there are any problems, read the INSTALL file."