summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Leadbeater <dgl@dgl.cx>2014-07-07 22:41:38 +0100
committerDavid Leadbeater <dgl@dgl.cx>2014-07-07 22:41:38 +0100
commit663bd7ee233bfa3d5ec86e5b3b5a5f700a04176b (patch)
tree65e1ce7cfaaa7befb89bdda7415b9493453d80be /configure.ac
parenta9ff985a919b90ab047d9d98d982b2cab8cd9565 (diff)
downloadirssi-663bd7ee233bfa3d5ec86e5b3b5a5f700a04176b.zip
Add some more helpful hints about packages to install to configure output
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 25 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 29fee0bd..2a7bee0d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -303,6 +303,15 @@ if test -z "$GLIB_LIBS"; then
echo "*** We recommend you get the latest stable GLIB 2 version."
echo "*** Compile and install it, and make sure pkg-config finds it,"
echo "*** by adding the path where the .pc file is located to PKG_CONFIG_PATH"
+ echo -n "*** Or alternatively install your distribution's package"
+ if test -f /etc/debian_version; then
+ echo :
+ echo "*** sudo apt-get install libglib2.0-dev"
+ elif test -f /etc/redhat-release; then
+ echo " (glib2-devel)"
+ else
+ echo .
+ fi
echo
AC_ERROR([GLIB is required to build irssi.])
@@ -384,7 +393,7 @@ if test "x$want_textui" = "xyes"; then
TEXTUI_LIBS="-ltermcap"
want_termcap=yes
], [
- AC_ERROR(Terminfo/termcap not found - install ncurses-devel package)
+ AC_ERROR(Terminfo/termcap not found - install libncurses-dev or ncurses-devel package)
want_textui=no
])))
fi
@@ -741,6 +750,11 @@ else
else
echo "Building with Perl support ....... : NO!"
echo " - $perl_check_error"
+ if test -f /etc/debian_version; then
+ echo " - Try: sudo apt-get install libperl-dev"
+ elif test -f /etc/redhat-release; then
+ echo " - Try installing perl-devel"
+ fi
fi
fi
@@ -750,7 +764,7 @@ if test "x$want_perl" != "xno" -a "x$perl_mod_error" != "x"; then
echo " $perl_mod_error"
if test -f /etc/debian_version; then
- echo " - Try: apt-get install libperl-dev"
+ echo " - Try: sudo apt-get install libperl-dev"
fi
fi
@@ -775,6 +789,15 @@ echo
echo "Building with IPv6 support ....... : $have_ipv6"
echo "Building with SSL support ........ : $have_openssl"
+if test "x$have_openssl" = "xno" -a "x$enable_ssl" = "xyes"; then
+ if test -f /etc/debian_version; then
+ echo " - Try: sudo apt-get install libssl-dev"
+ elif test -f /etc/redhat-release; then
+ echo " - Try installing openssl-devel"
+ else
+ echo " - Try installing OpenSSL development headers"
+ fi
+fi
echo "Building with 64bit DCC support .. : $offt_64bit"
echo "Building with garbage collector .. : $have_gc"
echo "Building with DANE support ....... : $have_dane"