summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexander Færøy <ahf@0x90.dk>2015-09-20 20:54:29 +0200
committerAlexander Færøy <ahf@0x90.dk>2015-09-20 21:28:14 +0200
commit29cf546ee4d5c1af1042d6fbeaae150ecc545d4a (patch)
treea8162bab5da2e1ad0436817aed7548c37c4381af /configure.ac
parent9586766d87820bdfa9e7cbe805f5ed4b7b0378e5 (diff)
downloadirssi-29cf546ee4d5c1af1042d6fbeaae150ecc545d4a.zip
Remove Garbage Collection support.
GC support was never enabled by default and nobody in the current development team seems to care about it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 0 insertions, 32 deletions
diff --git a/configure.ac b/configure.ac
index c312d065..e33b8c1d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -83,15 +83,6 @@ if test "x$prefix" != "xNONE"; then
perl_prefix_note=yes
fi
-AC_ARG_WITH(gc,
-[ --with-gc Use garbage collector],
- if test x$withval = xno; then
- want_gc=no
- else
- want_gc=yes
- fi,
- want_gc=no)
-
AC_ARG_WITH(perl-staticlib,
[ --with-perl-staticlib Specify that we want to link perl libraries
statically in irssi, default is no],
@@ -323,28 +314,6 @@ if test "$enable_ssl" = "yes"; then
fi
dnl **
-dnl ** Garbage Collector
-dnl **
-have_gc=no
-if test "x$want_gc" = xyes; then
- AC_CHECK_LIB(gc, GC_malloc, [
- AC_CHECK_HEADER(gc/gc.h, [
- AC_DEFINE(HAVE_GC_GC_H)
- AC_DEFINE(USE_GC)
- LIBS="$LIBS -lgc"
- have_gc=yes
- ], [
- AC_CHECK_HEADER(gc.h, [
- AC_DEFINE(HAVE_GC_H)
- AC_DEFINE(USE_GC)
- LIBS="$LIBS -lgc"
- have_gc=yes
- ])
- ])
- ])
-fi
-
-dnl **
dnl ** curses checks
dnl **
@@ -782,7 +751,6 @@ if test "x$have_openssl" = "xno" -a "x$enable_ssl" = "xyes"; then
fi
fi
echo "Building with 64bit DCC support .. : $offt_64bit"
-echo "Building with garbage collector .. : $have_gc"
echo "Building with DANE support ....... : $have_dane"
echo "Building with true color support.. : $want_truecolor"