summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFrançois Revol <revol@free.fr>2014-07-22 22:36:49 +0200
committerFrançois Revol <revol@free.fr>2014-07-22 22:50:42 +0200
commit1f9ad64ee559b05463c09796ef20b4dbe0daa37d (patch)
treeb803d9db3eb1a426633524ab5c4267ff13024ac5 /configure.ac
parent9af3df4e9d1ecfc070fe79d0cd20e035986b33b2 (diff)
downloadirssi-1f9ad64ee559b05463c09796ef20b4dbe0daa37d.zip
Simplify socklen_t type detection
The previous version of AC_CHECK_TYPE() which didn't accept passing headers is obsolete anyway. The new one can be told which headers to include. Also test for sys/socket.h just for sanity. cf. https://www.gnu.org/software/autoconf/manual/autoconf-2.69/html_node/Obsolete-Macros.html https://www.gnu.org/software/autoconf/manual/autoconf-2.64/html_node/Generic-Types.html https://svn.opendnssec.org/home/jerry/memory-usage/ldns-1.6.10/acx_nlnetlabs.m4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 8 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 360af621..f587b93c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,7 +20,7 @@ AC_PATH_PROG(perlpath, perl)
AC_CHECK_HEADERS(unistd.h dirent.h sys/ioctl.h sys/resource.h)
# check posix headers..
-AC_CHECK_HEADERS(sys/time.h sys/utsname.h regex.h)
+AC_CHECK_HEADERS(sys/socket.h sys/time.h sys/utsname.h regex.h)
AC_SYS_LARGEFILE
@@ -206,21 +206,13 @@ if test "x$ac_cv_prog_gcc" = "xyes"; then
CFLAGS="$CFLAGS -Wall"
fi
-dnl * socklen_t - AC_CHECK_TYPE() would be _really_ useful if it only would
-dnl * accept header files where to find the typedef..
-AC_MSG_CHECKING([for socklen_t])
-AC_CACHE_VAL(irssi_cv_type_socklen_t,
-[AC_TRY_COMPILE([
-#include <sys/types.h>
-#include <sys/socket.h>],
-[socklen_t t = 0; return((int)t); ],
-irssi_cv_type_socklen_t=yes,
-irssi_cv_type_socklen_t=no,
-)])
-if test $irssi_cv_type_socklen_t = no; then
-AC_DEFINE(socklen_t, int, Define to 'int' if <sys/socket.h> doesn't define.)
-fi
-AC_MSG_RESULT($irssi_cv_type_socklen_t)
+AC_CHECK_TYPE(socklen_t, ,
+ [AC_DEFINE([socklen_t], [int], [Define to 'int' if <sys/socket.h> doesn't define.])], [
+AC_INCLUDES_DEFAULT
+#ifdef HAVE_SYS_SOCKET_H
+# include <sys/socket.h>
+#endif
+])
AC_CHECK_SIZEOF(int)
AC_CHECK_SIZEOF(long)