summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/rules5
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index c0cb4b218..b3f4798fd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -46,6 +46,9 @@ installation-guide (20220213) UNRELEASED; urgency=medium
Resolution about non-free firmware and all the changes that were
implemented since then.
* buildone.sh: skip PDF generation for Greek (el), since xelatex fails.
+ * rules: Avoid “Fontconfig error: No writable cache directories” (seen
+ during PDF generation) in chroots, by setting HOME to a writable
+ location, inside the build tree.
-- Philip Hands <phil@hands.com> Tue, 11 Oct 2022 21:08:00 +0200
diff --git a/debian/rules b/debian/rules
index 398804d67..5a924af28 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,13 +18,16 @@ endif
export FORCE_SOURCE_DATE=1
+# Avoid “Fontconfig error: No writable cache directories” in chroots:
+export HOME=$(CURDIR)/debian/fake-home
+
MANTMP=$(shell pwd)/debian/manual
clean:
dh_testdir
dh_testroot
dh_clean build-stamp
- rm -rf $(MANTMP)
+ rm -rf $(MANTMP) $(CURDIR)/debian/fake-home
dh_clean doc-base-stamp
rm -rf debian/installation-guide-*.doc-base.*
rm -rf build/build.out* build/build.tmp* build/build.po