summaryrefslogtreecommitdiff
path: root/aports/wpa_passthru/APKBUILD
diff options
context:
space:
mode:
authorPÁLI Gábor János <pali.gabor@gmail.com>2022-04-10 18:17:21 +0200
committerPÁLI Gábor János <pali.gabor@gmail.com>2022-04-10 23:09:31 +0200
commitbcbf7c6c9fc7d8a96b1d5c4cc9247b85fe3da2ad (patch)
tree46d796182b2249408b0597485462ef1698dc4c13 /aports/wpa_passthru/APKBUILD
parent40d2daea11738408b7bf7b60f14a558ff8c47fb0 (diff)
downloadfreebsd-wifibox-alpine-bcbf7c6c9fc7d8a96b1d5c4cc9247b85fe3da2ad.zip
Move towards custom packages.
Change the build image process in a way that custom-built packages can be utilized. This means a simpler `Makefile` since every modification is implemented on the level of packages. Include the sources for every customized package.
Diffstat (limited to 'aports/wpa_passthru/APKBUILD')
-rw-r--r--aports/wpa_passthru/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/aports/wpa_passthru/APKBUILD b/aports/wpa_passthru/APKBUILD
new file mode 100644
index 0000000..5672428
--- /dev/null
+++ b/aports/wpa_passthru/APKBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Gabor Pali <pali.gabor@gmail.com>
+
+pkgname=wpa_passthru
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="WPA Supplicant pass-through for Wifibox"
+url="https://github.com/pgj/freebsd-wifibox-alpine"
+arch="all"
+license="BSD2"
+install=""
+subpackages=
+source="wpa_passthru.initd
+ wpa_passthru
+"
+
+package() {
+ install -D -m755 "$srcdir"/wpa_passthru.initd "$pkgdir"/etc/init.d/wpa_passthru
+ install -D -m755 "$srcdir"/wpa_passthru "$pkgdir"/sbin/wpa_passthru
+}
+sha512sums="
+ab107ef28b73517468c8e4558642b798fb3b6861e9ad92df4fd9912b5c3a56aa83822ce71ac1d4b84bf3113dc9c8c1aec6a76e3be17f0613ee722108a384e3ff wpa_passthru.initd
+46178341d5cd323bc2e7bdf1f21158e7806f6746efe480f1f0f9b57254355b78def8e90d5f5e87e10122b04f6280da711865640ee38faa7566c5da0f3d9f18c3 wpa_passthru
+"