summaryrefslogtreecommitdiff
path: root/aports/uds_passthru
diff options
context:
space:
mode:
authorPÁLI Gábor János <pali.gabor@gmail.com>2022-11-29 04:53:11 +0100
committerPÁLI Gábor János <pali.gabor@gmail.com>2022-11-29 05:19:56 +0100
commitc0713400778eb412d113ea217982a586d79f35fe (patch)
tree1daa03547c5f1c17a624a72f7a14f9d17f1ed58e /aports/uds_passthru
parent14a3e2bad5c174b8a4ee5a4890e16145a23f39f1 (diff)
downloadfreebsd-wifibox-alpine-c0713400778eb412d113ea217982a586d79f35fe.zip
Implement a forwarding service.
- Add the `forwarding` system service (script + OpenRC support). - Enable support for UDP ports for `socat`. - Adjust UDS pass-through to avoid conflicts with forwarding. - Update documentation. Requested by: Universal Devices
Diffstat (limited to 'aports/uds_passthru')
-rw-r--r--aports/uds_passthru/APKBUILD4
-rw-r--r--aports/uds_passthru/uds_passthru4
2 files changed, 4 insertions, 4 deletions
diff --git a/aports/uds_passthru/APKBUILD b/aports/uds_passthru/APKBUILD
index 41cfa4d..1fd7d07 100644
--- a/aports/uds_passthru/APKBUILD
+++ b/aports/uds_passthru/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gabor Pali <pali.gabor@gmail.com>
pkgname=uds_passthru
-pkgver=0.1.0
+pkgver=0.1.1
pkgrel=0
pkgdesc="Unix Domain Socket pass-through for Wifibox"
url="https://github.com/pgj/freebsd-wifibox-alpine"
@@ -22,5 +22,5 @@ package() {
}
sha512sums="
efb66ffbfde79321b534c8427bbb77bbb298175fb30be8c79f21e091ed3b942d8260020996e15d62ada60de778d38d5352f4f323bd7023672b4b778e4ef1318f uds_passthru.initd
-bc83be88e395dd73d1ba5e65d23dde045918b763b1562b3ebd17beb35e3599ca44f78dd6a732815fd6aecb0e6f8ae97ea70ef359620bf14c9ffbe88c5005ad00 uds_passthru
+7c04a8b4b39b15d18f3708144ab76c30bc50b8b4747546d7ba6123801f3ef7a6cf71644ddfb636209c5b9e9de60f442ea807205773e54ab8fdf3c3eccfcd237e uds_passthru
"
diff --git a/aports/uds_passthru/uds_passthru b/aports/uds_passthru/uds_passthru
index 95e0931..ba26b78 100644
--- a/aports/uds_passthru/uds_passthru
+++ b/aports/uds_passthru/uds_passthru
@@ -104,8 +104,8 @@ _block=$!
log info "Waiting for PID ${_block} to stop."
wait "${_block}"
-_socats=$(/usr/bin/pgrep socat)
-log info "Stopping, socat processes: [${_socats}]"
+_socats=$(/usr/bin/pgrep -P $$ socat)
+log info "Stopping, own socat processes: [${_socats}]"
# shellcheck disable=SC2086
[ -n "${_socats}" ] && /bin/kill -TERM ${_socats}