summaryrefslogtreecommitdiff
path: root/aports/uds_passthru/APKBUILD
diff options
context:
space:
mode:
authorPÁLI Gábor János <pali.gabor@gmail.com>2022-05-28 12:44:37 +0200
committerPÁLI Gábor János <pali.gabor@gmail.com>2022-05-31 22:02:42 +0200
commit97c67abab07a57840f95d04fadbd13b3c0f5b328 (patch)
treecdd484a2af71b89ff7a75c5eb808e6e18f00801d /aports/uds_passthru/APKBUILD
parenta6085330a18c8a257d2e185aab016c483335f86a (diff)
downloadfreebsd-wifibox-alpine-97c67abab07a57840f95d04fadbd13b3c0f5b328.zip
Incorporate `hostapd`.
The inclusion of `hostapd` [1] brings a lot of related changes because the build process have to extended to take the challenge. - Convert `wpa_passthru` to a more a generic services, called `uds_passthru` to deal with the control socket forwarding. It can also log the `socat` errors properly. - Make the `Makefile` more parametric therefore the virtual disk image can be customized better. - Default configurations are now moved fully to the guest's side. - Tweak the packages to be more flexible. - Document everything. [1] https://w1.fi/hostapd/
Diffstat (limited to 'aports/uds_passthru/APKBUILD')
-rw-r--r--aports/uds_passthru/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/aports/uds_passthru/APKBUILD b/aports/uds_passthru/APKBUILD
new file mode 100644
index 0000000..41cfa4d
--- /dev/null
+++ b/aports/uds_passthru/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Gabor Pali <pali.gabor@gmail.com>
+
+pkgname=uds_passthru
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Unix Domain Socket pass-through for Wifibox"
+url="https://github.com/pgj/freebsd-wifibox-alpine"
+arch="all"
+license="BSD2"
+depends="socat"
+install=""
+subpackages=
+options="!check"
+arch="noarch"
+source="uds_passthru.initd
+ uds_passthru
+"
+
+package() {
+ install -D -m755 "$srcdir"/uds_passthru.initd "$pkgdir"/etc/init.d/uds_passthru
+ install -D -m755 "$srcdir"/uds_passthru "$pkgdir"/sbin/uds_passthru
+}
+sha512sums="
+efb66ffbfde79321b534c8427bbb77bbb298175fb30be8c79f21e091ed3b942d8260020996e15d62ada60de778d38d5352f4f323bd7023672b4b778e4ef1318f uds_passthru.initd
+bc83be88e395dd73d1ba5e65d23dde045918b763b1562b3ebd17beb35e3599ca44f78dd6a732815fd6aecb0e6f8ae97ea70ef359620bf14c9ffbe88c5005ad00 uds_passthru
+"