summaryrefslogtreecommitdiff
path: root/aports/socat
diff options
context:
space:
mode:
authorPÁLI Gábor János <pali.gabor@gmail.com>2024-03-16 13:33:00 +0100
committerPÁLI Gábor János <pali.gabor@gmail.com>2024-03-16 13:44:13 +0100
commitd7e702dd5529860e3d97a84e387bad95573f5894 (patch)
treee4c8bff35d942fadd35d2cd76a93ca4994fb55cb /aports/socat
parentf9967eae7a169b920daedecbc176c792d516f471 (diff)
downloadfreebsd-wifibox-alpine-d7e702dd5529860e3d97a84e387bad95573f5894.zip
Update to Linux 6.6 & 6.8, and Alpine 3.19
- Update dhcpcd to 10.0.5 - Update iptables to 1.8.10 - Update linux-lts to 6.6.22 - Update linux-edge to 6.8.1 - Update openrc 0.52.1 - Update mDNSResponder to 2200.80.16 - Update rtl8821ce to snapshot of 20240120 - Update rtw88 to snapshot of 20231024 - Resolve driver conflict between rtw88 and rtl8821ce - Update rtw89 to snapshot of 20240310 - Update socat to 1.8.0.0 - Import security fixes for wpa_supplicant
Diffstat (limited to 'aports/socat')
-rw-r--r--aports/socat/APKBUILD16
-rw-r--r--aports/socat/no-extras.patch49
2 files changed, 49 insertions, 16 deletions
diff --git a/aports/socat/APKBUILD b/aports/socat/APKBUILD
index 5fd3a09..7da4946 100644
--- a/aports/socat/APKBUILD
+++ b/aports/socat/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Gabor Pali <pali.gabor@gmail.com>
pkgname=socat
-pkgver=1.7.4.4
-pkgrel=1 # base: 1
+pkgver=1.8.0.0
+pkgrel=0 # base: 0
pkgdesc="Multipurpose relay for binary protocols (stripped)"
options="!check"
url="http://www.dest-unreach.org/socat/"
@@ -37,15 +37,21 @@ _options="--srcdir=$_srcdir
--disable-creat
--disable-gopen
--disable-pipe
- --disable-termios
+ --disable-socketpair
+ --disable-shell
+ --disable-stats
--disable-ip6
--disable-rawip
--disable-genericsocket
--disable-interface
--disable-sctp
+ --disable-dccp
--disable-vsock
+ --disable-namespaces
+ --disable-posixmq
--disable-socks4
--disable-socks4a
+ --disable-socks5
--disable-proxy
--disable-exec
--disable-system
@@ -91,8 +97,8 @@ _udp() {
}
sha512sums="
-709fd393642d4249152d75add4d489ea76e6118c9e6740e796f029e8c5ddd4f5c9218d587977fc57ada640f635a996cbbe4055275236a169881bb2be1d3e5df9 socat-1.7.4.4.tar.gz
+edf459a9f1907a14025e13b3101ad29787f9a72795cffcd00017ce98847562884db29a95b9ae478a6a50868137548b142947c43fb18e975eb5853a763c42902c socat-1.8.0.0.tar.gz
2032b6528cb27b69d8fb6a6f64af32fcc1f6e4934bb0d7c8931b38ab7ad5e27f6f4344a6cf49751fa3178cd725f954e195373362f7d5929e587d7f0309346059 use-linux-headers.patch
22a6e0c2317a9317997c98114daac258ebbcc3d8e58e49a6ebf24781b98967afed47c63807282582fa0909076fe349281f05e4462faacb90e7aabc853903d6e6 netdb-internal.patch
-de2ca2d318ada9ac7140ad6fbc42006ea0ef040d68cc579ed1452246fd16a7eceb4ce577336bc20e513cf6fe24da296447529ec36c22fa17a4c18be29e180b81 no-extras.patch
+017c0b51e416ae7f199885d808173b40ba72a419dbe946d692a044a81dcffd0c38e40a99abb7d1cbed01d132c5a9adfc5f9a1de1fe4e8a4ff7d22ed7b0ec53d3 no-extras.patch
"
diff --git a/aports/socat/no-extras.patch b/aports/socat/no-extras.patch
index 94bd71a..34af2ce 100644
--- a/aports/socat/no-extras.patch
+++ b/aports/socat/no-extras.patch
@@ -1,45 +1,72 @@
---- socat-1.7.4.2/Makefile.in.orig 2022-04-01 22:07:25.284535646 +0000
-+++ socat-1.7.4.2/Makefile.in 2022-04-01 22:09:04.484450962 +0000
-@@ -57,7 +57,7 @@
+--- socat-1.8.0.0/Makefile.in.orig
++++ socat-1.8.0.0/Makefile.in
+@@ -58,9 +58,9 @@
+ XIOOBJS = $(XIOSRCS:.c=.o)
+ UTLSRCS = error.c dalan.c procan.c procan-cdefs.c hostan.c fdname.c sysutils.c utils.c nestlex.c vsnprintf_r.c snprinterr.c @FILAN@ sycls.c @SSLCLS@
UTLOBJS = $(UTLSRCS:.c=.o)
- CFILES = $(XIOSRCS) $(UTLSRCS) socat.c procan_main.c filan_main.c
+-CFILES = $(XIOSRCS) $(UTLSRCS) socat.c procan_main.c filan_main.c
++CFILES = $(XIOSRCS) $(UTLSRCS) socat.c
OFILES = $(CFILES:.c=.o)
-PROGS = socat procan filan
+PROGS = socat
HFILES = sycls.h sslcls.h error.h dalan.h procan.h filan.h hostan.h sysincludes.h xio.h xioopen.h sysutils.h utils.h nestlex.h vsnprintf_r.h snprinterr.h compat.h \
xioconfig.h mytypes.h xioopts.h xiodiag.h xiohelp.h xiosysincludes.h \
-@@ -87,7 +87,7 @@
- Config/Makefile.MacOSX-10-5 Config/config.MacOSX-10-5.h \
- Config/Makefile.DragonFly-2-8-2 Config/config.DragonFly-2-8-2.h
+@@ -82,7 +82,7 @@
+ TESTFILES = test.sh socks4echo.sh proxyecho.sh readline-test.sh \
+ proxy.sh socks4a-echo.sh
-all: progs doc
+all: progs
scmclean: gitclean
-@@ -131,19 +131,12 @@
+@@ -107,10 +107,10 @@
+ makedepend $(SYSDEFS) $(CFILES)
+
+ socat: socat.o libxio.a
+- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ socat.o libxio.a $(CLIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(CLIBS)
+
+ procan.o: procan.c
+- $(CC) $(CFLAGS) -c -D CC=\"$(CC)\" -o $@ procan.c
++ $(CC) $(CFLAGS) -c -D CC=\"$(CC)\" -o $@ $^
+
+ PROCAN_OBJS=procan_main.o procan.o procan-cdefs.o hostan.o error.o sycls.o sysutils.o utils.o vsnprintf_r.o snprinterr.o
+ procan: $(PROCAN_OBJS)
+@@ -128,29 +128,12 @@
strip: progs
strip $(PROGS)
-install: progs $(srcdir)/doc/socat.1
+install: progs
mkdir -p $(DESTDIR)$(BINDEST)
- $(INSTALL) -m 755 socat $(DESTDIR)$(BINDEST)
+- $(INSTALL) -m 755 socat $(DESTDIR)$(BINDEST)/socat1
+- ln -sf socat1 $(DESTDIR)$(BINDEST)/socat
+- $(INSTALL) -m 755 socat-chain.sh $(DESTDIR)$(BINDEST)
+- $(INSTALL) -m 755 socat-mux.sh $(DESTDIR)$(BINDEST)
+- $(INSTALL) -m 755 socat-broker.sh $(DESTDIR)$(BINDEST)
- $(INSTALL) -m 755 procan $(DESTDIR)$(BINDEST)
- $(INSTALL) -m 755 filan $(DESTDIR)$(BINDEST)
- mkdir -p $(DESTDIR)$(MANDEST)/man1
-- $(INSTALL) -m 644 $(srcdir)/doc/socat.1 $(DESTDIR)$(MANDEST)/man1/
+- $(INSTALL) -m 644 $(srcdir)/doc/socat.1 $(DESTDIR)$(MANDEST)/man1/socat1.1
+- ln -sf socat1.1 $(DESTDIR)$(MANDEST)/man1/socat.1
++ $(INSTALL) -m 755 socat $(DESTDIR)$(BINDEST)/socat
uninstall:
rm -f $(DESTDIR)$(BINDEST)/socat
+- rm -f $(DESTDIR)$(BINDEST)/socat1
+- rm -f $(DESTDIR)$(BINDEST)/socat-chain.sh
+- rm -f $(DESTDIR)$(BINDEST)/socat-mux.sh
+- rm -f $(DESTDIR)$(BINDEST)/socat-broker.sh
- rm -f $(DESTDIR)$(BINDEST)/procan
- rm -f $(DESTDIR)$(BINDEST)/filan
- rm -f $(DESTDIR)$(MANDEST)/man1/socat.1
+- rm -f $(DESTDIR)$(MANDEST)/man1/socat1.1
# make a GNU-zipped tar ball of the source files
dist: socat.tar.gz socat.tar.bz2
-@@ -165,7 +158,7 @@
+@@ -172,7 +155,7 @@
rm -r $(TARDIR)
clean: