summaryrefslogtreecommitdiff
path: root/aports/radvd/APKBUILD
diff options
context:
space:
mode:
authorPÁLI Gábor János <pali.gabor@gmail.com>2023-09-24 10:02:17 +0200
committerPÁLI Gábor János <pali.gabor@gmail.com>2023-09-26 11:53:45 +0200
commitcd4ad7988e34326f1cc9552c71e522c8d31b1cc3 (patch)
treef82dc373ce18f3a94163371af2d99399ad4ce978 /aports/radvd/APKBUILD
parente7633ba62583438640cdaa216c0f8f00bc37ad91 (diff)
downloadfreebsd-wifibox-alpine-cd4ad7988e34326f1cc9552c71e522c8d31b1cc3.zip
radvd: import
Diffstat (limited to 'aports/radvd/APKBUILD')
-rw-r--r--aports/radvd/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/aports/radvd/APKBUILD b/aports/radvd/APKBUILD
new file mode 100644
index 0000000..78e4a95
--- /dev/null
+++ b/aports/radvd/APKBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Gabor Pali <pali.gabor@gmail.com>
+#
+pkgname=radvd
+pkgver=2.19
+pkgrel=0 # base: 3
+pkgdesc="IPv6 router advertisement daemon"
+url="http://www.litech.org/radvd"
+arch="all"
+license="BSD with advertising"
+makedepends="flex bison linux-headers"
+install=
+source="http://www.litech.org/radvd/dist/radvd-$pkgver.tar.xz
+ radvd.initd
+ radvd.confd
+ fix-alpine-plz.patch
+ "
+options="!check"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc/ \
+ --without-check \
+ --with-pidfile=/run/radvd/radvd.pid
+ # work around parallel build issue
+ make gram.h && make
+}
+
+package() {
+ make -j1 DESTDIR="$pkgdir" install-exec
+ install -Dm755 "$srcdir"/radvd.initd "$pkgdir"/etc/init.d/radvd
+ install -Dm644 "$srcdir"/radvd.confd "$pkgdir"/etc/conf.d/radvd
+ ln -s /media/etc/radvd.conf "$pkgdir"/etc
+}
+
+sha512sums="
+a1eb40af90fc83ebab2517c16a0f7e85c11338ab276bec400b7c33177748d1e36bc5abd7e373b6742f12f7c690dd7ae6b951bc832c7de9bbb56f7e9bc844ed22 radvd-2.19.tar.xz
+fd78249b8ae25d1c55fc0b5cc2b3dd202388c0ca7be2737ecbd33ed5cd3c8616858aa46350967350fe8e8c0032552126918c8b9c36b13d799f3c5d8fb576fdf8 radvd.initd
+31cca1d48e5f0c4fe96a7a32ca6339e7aa9e478f7e9086f05bbc79ca59b1637d99e46079d7be77ef717a8fb975fada7664058e3bc61117309025b72f3e87d294 radvd.confd
+dffe4167c54c430fc38953e70d546fdf443944eceee4c610f14d63947fe8c04960b48a8acf5742edf8721558c4b811c9a4033ad9abe787ead9cc1bb0721b654c fix-alpine-plz.patch
+"