summaryrefslogtreecommitdiff
path: root/aports/openrc
diff options
context:
space:
mode:
authorPÁLI Gábor János <pali.gabor@gmail.com>2024-03-16 13:33:00 +0100
committerPÁLI Gábor János <pali.gabor@gmail.com>2024-03-16 13:44:13 +0100
commitd7e702dd5529860e3d97a84e387bad95573f5894 (patch)
treee4c8bff35d942fadd35d2cd76a93ca4994fb55cb /aports/openrc
parentf9967eae7a169b920daedecbc176c792d516f471 (diff)
downloadfreebsd-wifibox-alpine-d7e702dd5529860e3d97a84e387bad95573f5894.zip
Update to Linux 6.6 & 6.8, and Alpine 3.19
- Update dhcpcd to 10.0.5 - Update iptables to 1.8.10 - Update linux-lts to 6.6.22 - Update linux-edge to 6.8.1 - Update openrc 0.52.1 - Update mDNSResponder to 2200.80.16 - Update rtl8821ce to snapshot of 20240120 - Update rtw88 to snapshot of 20231024 - Resolve driver conflict between rtw88 and rtl8821ce - Update rtw89 to snapshot of 20240310 - Update socat to 1.8.0.0 - Import security fixes for wpa_supplicant
Diffstat (limited to 'aports/openrc')
-rw-r--r--aports/openrc/0001-sh-rc-cgroup.sh-add-openrc.-prefix-the-cgroupv2-path.patch57
-rw-r--r--aports/openrc/0009-Based-on-the-vrf-patch-it-adds-support-to-run-servic.patch30
-rw-r--r--aports/openrc/APKBUILD24
-rw-r--r--aports/openrc/sysctl-readme.patch11
4 files changed, 116 insertions, 6 deletions
diff --git a/aports/openrc/0001-sh-rc-cgroup.sh-add-openrc.-prefix-the-cgroupv2-path.patch b/aports/openrc/0001-sh-rc-cgroup.sh-add-openrc.-prefix-the-cgroupv2-path.patch
new file mode 100644
index 0000000..3b4ff76
--- /dev/null
+++ b/aports/openrc/0001-sh-rc-cgroup.sh-add-openrc.-prefix-the-cgroupv2-path.patch
@@ -0,0 +1,57 @@
+From abe447e2fbfb55d9fbff624bf44f46cb1c8622cb Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Fri, 15 Dec 2023 18:52:28 +0100
+Subject: [PATCH] sh/rc-cgroup.sh: add openrc. prefix the cgroupv2 path
+
+Some services, like docker, creates and manages /sys/fs/cgroup/<service>
+themselves. Avoid conflict with the openrc created cgroup path by adding
+a `openrc.` prefix.
+
+Fixes: https://github.com/OpenRC/openrc/issues/680
+---
+ sh/rc-cgroup.sh | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/sh/rc-cgroup.sh b/sh/rc-cgroup.sh
+index e5c7ae7f..f10e328c 100644
+--- a/sh/rc-cgroup.sh
++++ b/sh/rc-cgroup.sh
+@@ -35,7 +35,7 @@ cgroup_get_pids()
+ cgroup_pids=
+ cgroup_procs="$(cgroup2_find_path)"
+ if [ -n "${cgroup_procs}" ]; then
+- cgroup_procs="${cgroup_procs}/${RC_SVCNAME}/cgroup.procs"
++ cgroup_procs="${cgroup_procs}/openrc.${RC_SVCNAME}/cgroup.procs"
+ else
+ cgroup_procs="/sys/fs/cgroup/openrc/${RC_SVCNAME}/tasks"
+ fi
+@@ -167,7 +167,7 @@ cgroup2_remove()
+ local cgroup_path rc_cgroup_path
+ cgroup_path="$(cgroup2_find_path)"
+ [ -z "${cgroup_path}" ] && return 0
+- rc_cgroup_path="${cgroup_path}/${RC_SVCNAME}"
++ rc_cgroup_path="${cgroup_path}/openrc.${RC_SVCNAME}"
+ [ ! -d "${rc_cgroup_path}" ] ||
+ [ ! -e "${rc_cgroup_path}"/cgroup.events ] &&
+ return 0
+@@ -191,7 +191,7 @@ cgroup2_set_limits()
+ cgroup_path="$(cgroup2_find_path)"
+ [ -z "${cgroup_path}" ] && return 0
+ mountinfo -q "${cgroup_path}"|| return 0
+- rc_cgroup_path="${cgroup_path}/${RC_SVCNAME}"
++ rc_cgroup_path="${cgroup_path}/openrc.${RC_SVCNAME}"
+ [ ! -d "${rc_cgroup_path}" ] && mkdir "${rc_cgroup_path}"
+ [ -f "${rc_cgroup_path}"/cgroup.procs ] &&
+ printf 0 > "${rc_cgroup_path}"/cgroup.procs
+@@ -210,7 +210,7 @@ cgroup2_kill_cgroup() {
+ local cgroup_path
+ cgroup_path="$(cgroup2_find_path)"
+ [ -z "${cgroup_path}" ] && return 1
+- rc_cgroup_path="${cgroup_path}/${RC_SVCNAME}"
++ rc_cgroup_path="${cgroup_path}/openrc.${RC_SVCNAME}"
+ if [ -f "${rc_cgroup_path}"/cgroup.kill ]; then
+ printf "%d" 1 > "${rc_cgroup_path}"/cgroup.kill
+ fi
+--
+2.43.0
+
diff --git a/aports/openrc/0009-Based-on-the-vrf-patch-it-adds-support-to-run-servic.patch b/aports/openrc/0009-Based-on-the-vrf-patch-it-adds-support-to-run-servic.patch
new file mode 100644
index 0000000..bd149d9
--- /dev/null
+++ b/aports/openrc/0009-Based-on-the-vrf-patch-it-adds-support-to-run-servic.patch
@@ -0,0 +1,30 @@
+From 2f7405254f16cbb33ddb7c57eb20606a92b6c84a Mon Sep 17 00:00:00 2001
+From: Thomas Liske <thomas@fiasko-nw.net>
+Date: Sat, 16 Sep 2023 18:25:42 +0200
+Subject: [PATCH] Based on the vrf patch it adds support to run services in
+ netns namespaces. It is even possible to stack both options and run services
+ in a VRF inside a netns namespace.
+
+---
+ sh/openrc-run.sh.in | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/sh/openrc-run.sh.in b/sh/openrc-run.sh.in
+index 5eb4224c..2a6605db 100644
+--- a/sh/openrc-run.sh.in
++++ b/sh/openrc-run.sh.in
+@@ -242,6 +242,11 @@ if [ -n "$vrf" ]; then
+ RC_VRF_EXEC="/sbin/ip vrf exec $vrf"
+ fi
+
++# Add ip netns if configured to run in a netns (netns+vrf may stack)
++if [ -n "$netns" ]; then
++ RC_VRF_EXEC="/sbin/ip netns exec $netns $RC_VRF_EXEC"
++fi
++
+ # load service supervisor functions
+ sourcex "@LIBEXECDIR@/sh/runit.sh"
+ sourcex "@LIBEXECDIR@/sh/s6.sh"
+--
+2.39.2
+
diff --git a/aports/openrc/APKBUILD b/aports/openrc/APKBUILD
index 7efd42e..8b49f09 100644
--- a/aports/openrc/APKBUILD
+++ b/aports/openrc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gabor Pali <pali.gabor@gmail.com>
pkgname=openrc
-pkgver=0.48
-pkgrel=0 # base: 0
+pkgver=0.52.1
+pkgrel=0 # base: 2
pkgdesc="OpenRC manages the services, startup and shutdown of a host"
url="https://github.com/OpenRC/openrc"
arch="all"
@@ -21,8 +21,11 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/OpenRC/openrc/archive/$pkgve
0006-Add-support-for-starting-services-in-a-specified-VRF.patch
0007-Clean-up-staticroute-config-remove-irrelevant-parts-.patch
0008-bootmisc-switch-wipe_tmp-setting-to-no-by-default.patch
+ 0009-Based-on-the-vrf-patch-it-adds-support-to-run-servic.patch
supervise-daemon-defaults.patch
+ sysctl-readme.patch
+ 0001-sh-rc-cgroup.sh-add-openrc.-prefix-the-cgroupv2-path.patch
openrc.logrotate
hostname.initd
@@ -52,7 +55,11 @@ prepare() {
build() {
+ if [ -z "$BOOTSTRAP" ]; then
+ local lto="-Db_lto=true"
+ fi
abuild-meson \
+ $lto \
-Dzsh-completions=false \
-Dbash-completions=false \
-Dpam=false \
@@ -73,6 +80,11 @@ package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
+ # place .so's in /lib so fancy ancient separate partition /usr configs can
+ # load them
+ mv "$pkgdir"/usr/lib/*.so* "$pkgdir"/usr/lib/*.a \
+ "$pkgdir"/lib/
+
# Alpine does not use openrc as its init so delete
# openrc-init & openrc-shutdown to avoid confusion.
rm -f "$pkgdir"/sbin/openrc-init "$pkgdir"/sbin/openrc-shutdown
@@ -111,9 +123,6 @@ package() {
# openrc upstream removed service(8) for whatever reason, put it back
ln -s /sbin/rc-service "$pkgdir"/sbin/service
- # remove deprecated /sbin/runscript to avoid conflict with minicom
- rm "$pkgdir"/sbin/runscript
-
rm -rf "$pkgdir"/usr/share/man \
"$pkgdir"/usr/share/openrc \
"$pkgdir"/usr/include \
@@ -123,7 +132,7 @@ package() {
}
sha512sums="
-c67c0a1c87f44a6fde0a7634fcdff0683a821eef5183a4f3e1ef850d04dd7f6c23ec0a72b4a76d9f6c08cb34e362d5e204937caec549eadc638c286c2389c5ee openrc-0.48.tar.gz
+741f3f0752217b9ce159d00362d688738c5a84512ddd30c44f4f7f451d7950315a5e1de79eaf5e7b1cf6539a04f59600fbe82cc2a6ad966b735c2eb4d4f35717 openrc-0.52.1.tar.gz
257861f5f0562e9b9a9fccebae474bd75c4bb51f005a2b8132fd551f061f65863de46c5bc4437f137b4a9d3ca741f9de9274bfa7b418eda70497ed4b5fd3056d 0001-call-sbin-mkmntdirs-in-localmount-OpenRC-service.patch
3f47b4f7e6c5b7fb53ff8a13470fbada67f7470e5eba71a683e6c022162c3905f560d561c3d61698e3fde367d6ae715edf76e99949f52a22a3bbf79debc33f64 0002-fsck-don-t-add-C0-to-busybox-fsck.patch
0bd69d9e8e9c321a5e67cf924be07b9dd0b58801143c18f74bebf442958fc878e46a65f07cc2842566a8c3434e788ef3ca0c90c607de6b10931f01324bfc1b11 0003-rc-pull-in-sysinit-and-boot-as-stacked-levels-when-n.patch
@@ -132,7 +141,10 @@ c67c0a1c87f44a6fde0a7634fcdff0683a821eef5183a4f3e1ef850d04dd7f6c23ec0a72b4a76d9f
8bf00b82d7fc0eb1b529ec735009f91d277141ba7e5c04e23d10bbcf36eb453f0b31d48aec45e50b5be4c14f611acc4454933f3cefdf8beab07d851328223464 0006-Add-support-for-starting-services-in-a-specified-VRF.patch
431ac28808e684bea5511386bf5f06efe7f509f1dbe7e15ae6309563d813deae8f3edd872a0943ef8088e3cf778d7bc5ebd15a893dc4a08f4022b7a56bbafc63 0007-Clean-up-staticroute-config-remove-irrelevant-parts-.patch
475f4ea63b9b5d7eb9c623e96b6cc3d3072abcb7194d0045b84e0688836c8514fccfc68b0eae0b4bee60878cdea8042c3ce7e48406ee7a2f0e4a3e128a153468 0008-bootmisc-switch-wipe_tmp-setting-to-no-by-default.patch
+d7b8b1facd7fb9a6a8350912644cce3956947bcaa8bcb645f9c26a2bb0d062970efaa14bd66a7987f0748daff7b5a8e701b45b3fcca7c7c7e393ac262728f1a6 0009-Based-on-the-vrf-patch-it-adds-support-to-run-servic.patch
1323a8476580f7b56a9cf1b24b26b10da76c5916cf23d7dab01f08a3261751341dfe01d1ed884df8e6ea17ff6a52021cc40fb3101e99b77d4ae7f3f61ee330e8 supervise-daemon-defaults.patch
+903ff555275a67ff08da91badb55d9fa6c6a2901e8ef09ca8366bd74d69757491c8336347f04551268ecf053c8ae974f50decd869926894dd94e382008e3e925 sysctl-readme.patch
+8e31d1665bf4c1301473b0a9b508d645ff49f6f4afffb63b265c862178a15af156bffa0ef141bc850c05eae09806908cabb1e21ad939f556764632b3392c1f62 0001-sh-rc-cgroup.sh-add-openrc.-prefix-the-cgroupv2-path.patch
12bb6354e808fbf47bbab963de55ee7901738b4a912659982c57ef2777fff9a670e867fcb8ec316a76b151032c92dc89a950d7d1d835ef53f753a8f3b41d2cec openrc.logrotate
493f27d588e64bb2bb542b32493ed05873f4724e8ad1751002982d7b4e07963cfb72f93603b2d678f305177cf9556d408a87b793744c6b7cd46cf9be4b744c02 hostname.initd
787d783f91919c115809890f18d06d0812055f0aca42378e081d2cfbe2ff20a1db8d937b823ec4adbe0d380a6f02a2310dc74f6c3a2c36fd5d5371d51ad6d459 hwdrivers.initd
diff --git a/aports/openrc/sysctl-readme.patch b/aports/openrc/sysctl-readme.patch
new file mode 100644
index 0000000..df61aa1
--- /dev/null
+++ b/aports/openrc/sysctl-readme.patch
@@ -0,0 +1,11 @@
+diff --git a/sysctl.d/README b/sysctl.d/README
+index ca3e030..1b056a7 100644
+--- a/sysctl.d/README
++++ b/sysctl.d/README
+@@ -10,4 +10,5 @@ with .conf, or it will not be read.
+
+ The recommended location for local system settings is /etc/sysctl.d/local.conf
+ but as long as you follow the rules for the name of the file, anything will
+-work. see the sysctl.conf(5) man page for details of the format.
++work. see the sysctl.conf(5) man page for details of the format. This manpage
++can be found in the `procps-doc` package.