summaryrefslogtreecommitdiff
path: root/aports/base-layout
diff options
context:
space:
mode:
authorPÁLI Gábor János <pali.gabor@gmail.com>2023-08-03 10:10:44 +0200
committerPÁLI Gábor János <pali.gabor@gmail.com>2023-09-16 17:58:03 +0200
commit89279d87c5d3e0ea330be1f927e3f3bc59dbc2a7 (patch)
tree353bc9a026d0140151e760efbc4f6a6a6b24a020 /aports/base-layout
parent084335e136581edc28137b152cc559778224570e (diff)
downloadfreebsd-wifibox-alpine-89279d87c5d3e0ea330be1f927e3f3bc59dbc2a7.zip
Update to Linux 6.1 and Alpine 3.18
- Update base-layout to 3.4.3 - Update busybox to 1.36.1 - Update iptables to 1.8.9 - Update linux-lts to 6.1.53 - Update to openrc to 0.48 - Update rtl8821ce to snapshot of 20230915 - Replace rtwB88 with a third-party driver - Update rtw89 to snapshot of 20230913 - Import wpa_supplicant fixes from Arch Linux
Diffstat (limited to 'aports/base-layout')
-rw-r--r--aports/base-layout/20locale.sh (renamed from aports/base-layout/locale.sh)0
-rw-r--r--aports/base-layout/APKBUILD16
-rw-r--r--aports/base-layout/profile21
3 files changed, 9 insertions, 28 deletions
diff --git a/aports/base-layout/locale.sh b/aports/base-layout/20locale.sh
index bf75c08..bf75c08 100644
--- a/aports/base-layout/locale.sh
+++ b/aports/base-layout/20locale.sh
diff --git a/aports/base-layout/APKBUILD b/aports/base-layout/APKBUILD
index 9b46b78..cfc90b9 100644
--- a/aports/base-layout/APKBUILD
+++ b/aports/base-layout/APKBUILD
@@ -1,9 +1,9 @@
# Maintainer: Gabor Pali <pali.gabor@gmail.com>
-pkgname=baselayout
-pkgver=3.4.0
-pkgrel=0 # base: 0
-pkgdesc="Base dir structure and init scripts (Alpine Linux)"
+pkgname=baselayout # base: alpine-baselayout, alpine-baselayout-data
+pkgver=3.4.3
+pkgrel=0 # base: 1
+pkgdesc="Base dir structure and init scripts"
url="https://git.alpinelinux.org/cgit/aports/tree/main/alpine-baselayout"
arch="noarch"
license="GPL-2.0-only"
@@ -12,7 +12,7 @@ options="!fhs !check"
install=
_nbver=6.4
source="crontab
- locale.sh
+ 20locale.sh
group
inittab
@@ -100,7 +100,7 @@ package() {
install -m600 "$srcdir"/crontab "$pkgdir"/etc/crontabs/root
install -m644 \
- "$srcdir"/locale.sh \
+ "$srcdir"/20locale.sh \
"$pkgdir"/etc/profile.d/
cat > "$pkgdir"/etc/hosts <<-EOF
@@ -191,11 +191,11 @@ package() {
sha512sums="
6e169c0975a1ad1ad871a863e8ee83f053de9ad0b58d94952efa4c28a8c221445d9e9732ad8b52832a50919c2f39aa965a929b3d5b3f9e62f169e2b2e0813d82 crontab
-b2fc9b72846a43a45ba9a8749e581cef34d1915836833b51b7919dfbf4e275b7d55fec4dea7b23df3796380910971a41331e53e8cf0d304834e3da02cc135e5a locale.sh
+b2fc9b72846a43a45ba9a8749e581cef34d1915836833b51b7919dfbf4e275b7d55fec4dea7b23df3796380910971a41331e53e8cf0d304834e3da02cc135e5a 20locale.sh
806b8f23f823a9471846d12fa6b55690b95eedb4c613b82aefaba7ffef23f83e17552befd891a487864f72ef24e395d8611738933f684a85eb4c336cb20994f8 group
7cc3c23062c730ec7a1d7850423d9901047005520da5b347b7b24e5f33a9c9a9129b430557f7f41e565f143624b7f3c47e3f6e4a6a446e75f0ea245c03d70880 inittab
06d12a7b9ca14fe17e412d0f24814620b67d035ae859be7906cbf4782dd69e359a6a555dafb98060b7fb7e4714aaa676c88d9017cded36e6d8398e23369bb290 passwd
-a15252a5eb90983775f63e54d37242f4c76c5c358ad6d8c1622c7da35f1b8a722249e7375a07e9f08fbb25318bd1eb033d3927aed82c3f5e9b854ad550dad2ce profile
+4eb857ed59c2edb257636d2bf196989e514a273e9701e9f076c9ae8c1589b4898269180569960acf072c0981ec7ea54014fd230f014401d6bb92314285d1e6aa profile
3a00083bcdf5a9e884c9d07877d52311e3d99e79cbee656e236ba06e08ba0dddb7ba76494fdc9dd1a826c48e197a790a69e6bb458e9df64832d6b5e904e9fd15 protocols-6.4
47b0f3ee73af2d259bd206a026204be0ea25531a895a0b035a904b38fe5407bc3dd2beab7f8fcb3d760587e6159702ebdb9cbc4f508942befdf7f10c10c87888 services-6.4
"
diff --git a/aports/base-layout/profile b/aports/base-layout/profile
index e62587b..fbc3ba0 100644
--- a/aports/base-layout/profile
+++ b/aports/base-layout/profile
@@ -1,24 +1,5 @@
-# Append "$1" to $PATH when not already in.
-# Copied from Arch Linux, see #12803 for details.
-append_path () {
- case ":$PATH:" in
- *:"$1":*)
- ;;
- *)
- PATH="${PATH:+$PATH:}$1"
- ;;
- esac
-}
+export PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"
-append_path "/usr/local/sbin"
-append_path "/usr/local/bin"
-append_path "/usr/sbin"
-append_path "/usr/bin"
-append_path "/sbin"
-append_path "/bin"
-unset -f append_path
-
-export PATH
export PAGER=less
umask 022