summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/xpi-server_spy/Makefile56
-rw-r--r--www/xpi-server_spy/distinfo2
-rw-r--r--www/xpi-server_spy/pkg-descr4
4 files changed, 63 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index ecc6945e2fc4..3f28f645ce9c 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -2021,6 +2021,7 @@
SUBDIR += xpi-savegenpage
SUBDIR += xpi-scrapbook
SUBDIR += xpi-searchstatus
+ SUBDIR += xpi-server_spy
SUBDIR += xpi-server_switcher
SUBDIR += xpi-sessionmanager
SUBDIR += xpi-showip
diff --git a/www/xpi-server_spy/Makefile b/www/xpi-server_spy/Makefile
new file mode 100644
index 000000000000..46100fc6331e
--- /dev/null
+++ b/www/xpi-server_spy/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: xpi-server_spy
+# Date created: 10 November 2011
+# Whom: Barbara <barbara.xxx1975@libero.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= server_spy
+PORTVERSION= 0.2.1
+DISTVERSIONSUFFIX= -fx
+CATEGORIES= www
+
+MAINTAINER= barbara.xxx1975@libero.it
+COMMENT= Indicates what brand of HTTP server runs on the visited site
+
+USE_XPI= *firefox*
+
+XPI_ID= ServerSpy@jacquet.eu.org
+XPI_NUM= 2036
+XPI_FILES= defaults/preferences/prefs.js \
+ chrome/chromeFiles/locale/fr-FR/ui.properties \
+ chrome/chromeFiles/locale/fr-FR/ui.ent \
+ chrome/chromeFiles/locale/fr-FR/contents.rdf \
+ chrome/chromeFiles/locale/en-US/ui.properties \
+ chrome/chromeFiles/locale/en-US/ui.ent \
+ chrome/chromeFiles/locale/en-US/contents.rdf \
+ chrome/chromeFiles/content/unknown.png \
+ chrome/chromeFiles/content/statusbar.xul \
+ chrome/chromeFiles/content/serverspy.js \
+ chrome/chromeFiles/content/serverspy-32.png \
+ chrome/chromeFiles/content/overlay.xul \
+ chrome/chromeFiles/content/options.xul \
+ chrome/chromeFiles/content/n.png \
+ chrome/chromeFiles/content/addonbar.xul \
+ chrome/chromeFiles/content/about.xul \
+ chrome/chromeFiles/content/L.png \
+ chrome/chromeFiles/content/I.png \
+ chrome/chromeFiles/content/G.png \
+ chrome/chromeFiles/content/A.png \
+ chrome.manifest \
+ install.rdf
+
+XPI_DIRS= defaults/preferences defaults \
+ chrome/chromeFiles/locale/fr-FR \
+ chrome/chromeFiles/locale/en-US \
+ chrome/chromeFiles/locale \
+ chrome/chromeFiles/content chrome/chromeFiles chrome
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|4\.0b8pre|8.*|' ${WRKSRC}/install.rdf
+
+pre-install:
+ @${RM} -f ${WRKSRC}/install.rdf.bak
+
+.include "${.CURDIR}/../xpi-adblock/Makefile.xpi"
+.include <bsd.port.mk>
diff --git a/www/xpi-server_spy/distinfo b/www/xpi-server_spy/distinfo
new file mode 100644
index 000000000000..d0a819323e0e
--- /dev/null
+++ b/www/xpi-server_spy/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xpi/server_spy-0.2.1-fx.xpi) = 7964de5564082de283eba55a47e42b5d58fcf6e59c2283458f5e82ed9387844f
+SIZE (xpi/server_spy-0.2.1-fx.xpi) = 28936
diff --git a/www/xpi-server_spy/pkg-descr b/www/xpi-server_spy/pkg-descr
new file mode 100644
index 000000000000..f87993b55151
--- /dev/null
+++ b/www/xpi-server_spy/pkg-descr
@@ -0,0 +1,4 @@
+Server Spy indicates what brand of HTTP server (e.g. Apache, IIS, etc.)
+runs on the visited sites.
+
+WWW: http://releases.mozilla.org/pub/mozilla.org/addons/2036/