summaryrefslogtreecommitdiff
path: root/www/py-dj41-django-cors-headers/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-dj41-django-cors-headers/Makefile')
-rw-r--r--www/py-dj41-django-cors-headers/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/www/py-dj41-django-cors-headers/Makefile b/www/py-dj41-django-cors-headers/Makefile
index 61b933eaa026..64620d5500f5 100644
--- a/www/py-dj41-django-cors-headers/Makefile
+++ b/www/py-dj41-django-cors-headers/Makefile
@@ -1,8 +1,9 @@
PORTNAME= django-cors-headers
-PORTVERSION= 3.13.0
+PORTVERSION= 3.14.0
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}dj41-
+DISTNAME= django_cors_headers-${PORTVERSION}
MAINTAINER= kai@FreeBSD.org
COMMENT= Handles server headers required for Cross-Origin Resource Sharing
@@ -11,10 +12,12 @@ WWW= https://github.com/adamchainz/django-cors-headers
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django41>=3.2:www/py-django41@${PY_FLAVOR}
USES= python:3.8+
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist pep517
NO_ARCH= yes
CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}*${PORTNAME}