summaryrefslogtreecommitdiff
path: root/www/libnghttp2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/libnghttp2/Makefile')
-rw-r--r--www/libnghttp2/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/www/libnghttp2/Makefile b/www/libnghttp2/Makefile
index 5b3b17eddd77..e9e7c1cbaef6 100644
--- a/www/libnghttp2/Makefile
+++ b/www/libnghttp2/Makefile
@@ -1,8 +1,7 @@
PORTNAME= nghttp2
-PORTVERSION= 1.51.0
-PORTREVISION= 1
+DISTVERSION= 1.52.0
CATEGORIES= www net
-MASTER_SITES= https://github.com/nghttp2/nghttp2/releases/download/v${PORTVERSION}/
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${DISTVERSION}/
PKGNAMEPREFIX= lib
MAINTAINER= sunpoet@FreeBSD.org
@@ -12,12 +11,12 @@ WWW= https://nghttp2.org/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= compiler:c++14-lang cpe libtool pathfix pkgconfig tar:xz
-
-CONFIGURE_ARGS= --enable-lib-only
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
-USE_CXXSTD= c++14
+USES= cmake compiler:c++14-lang cpe libtool pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
+CMAKE_OFF= ENABLE_DOC \
+ ENABLE_HTTP3
+CMAKE_ON= ENABLE_LIB_ONLY \
+ ENABLE_STATIC_LIB
+
.include <bsd.port.mk>