summaryrefslogtreecommitdiff
path: root/textproc/py-xhtml2pdf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/py-xhtml2pdf/Makefile')
-rw-r--r--textproc/py-xhtml2pdf/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/textproc/py-xhtml2pdf/Makefile b/textproc/py-xhtml2pdf/Makefile
index 8704e686df7a..3d964787c5d4 100644
--- a/textproc/py-xhtml2pdf/Makefile
+++ b/textproc/py-xhtml2pdf/Makefile
@@ -17,7 +17,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}html5lib>=1.0:www/py-html5lib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pdf2>=0:print/py-pdf2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}reportlab>=3.0:print/py-reportlab@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR} \
+ ${PY_PILLOW}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=1.0:devel/py-nose@${PY_FLAVOR}
USES= python
@@ -25,12 +26,4 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 3500
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>=0:graphics/py-pillow6@${PY_FLAVOR}
-.else
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>