summaryrefslogtreecommitdiff
path: root/textproc/libextractor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/libextractor/Makefile')
-rw-r--r--textproc/libextractor/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/textproc/libextractor/Makefile b/textproc/libextractor/Makefile
index 49884aeac5eb..68703b628b68 100644
--- a/textproc/libextractor/Makefile
+++ b/textproc/libextractor/Makefile
@@ -21,8 +21,8 @@ USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
USE_LDCONFIG= ${PREFIX}/lib/libextractor
CONFIGURE_ARGS= --disable-ltdl-install
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE= yes
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude libltdl
@@ -113,7 +113,7 @@ PLIST_SUB+= RPM="@comment "
# QT can be disabled
.if !defined(WITHOUT_QT)
LIB_DEPENDS+= QtGui:${PORTSDIR}/x11-toolkits/qt4-gui
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib -L${LOCALBASE}/lib/qt4"
+LDFLAGS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib/qt4
CONFIGURE_ARGS+=--with-qt=${LOCALBASE}
PLIST_SUB+= QT=""
.else