summaryrefslogtreecommitdiff
path: root/sysutils/logstalgia/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/logstalgia/Makefile')
-rw-r--r--sysutils/logstalgia/Makefile32
1 files changed, 21 insertions, 11 deletions
diff --git a/sysutils/logstalgia/Makefile b/sysutils/logstalgia/Makefile
index 5da3e78a0249..09b80bb2a906 100644
--- a/sysutils/logstalgia/Makefile
+++ b/sysutils/logstalgia/Makefile
@@ -2,27 +2,37 @@
# $FreeBSD$
PORTNAME= logstalgia
-PORTVERSION= 1.0.3
-PORTREVISION= 9
+PORTVERSION= 1.0.7
CATEGORIES= sysutils www
-MASTER_SITES= GOOGLE_CODE LOCAL/ehaupt
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Website access log visualization tool
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= Unfetchable (google code has gone away)
-
-LIB_DEPENDS= libftgl.so:graphics/ftgl \
+BUILD_DEPENDS= ${LOCALBASE}/include/glm/glm.hpp:math/glm
+LIB_DEPENDS= libboost_regex.so:devel/boost-libs \
+ libfreetype.so:print/freetype2 \
+ libpcre.so:devel/pcre \
libpng.so:graphics/png \
- libpcre.so:devel/pcre
+ libftgl.so:graphics/ftgl
+
+USE_GITHUB= yes
+GH_ACCOUNT= acaudwell
+GH_PROJECT= Logstalgia:DEFAULT Core:core
+GH_TAGNAME= d99bdb2:DEFAULT 83eba3a:core
GNU_CONFIGURE= yes
-USES= jpeg pkgconfig
-USE_GL= gl glu
-USE_SDL= image sdl
+USES= autoreconf compiler:c++0x gmake jpeg localbase:ldflags pkgconfig
+USE_GL= gl glu glew
+USE_SDL= image2 sdl2
+
+post-extract:
+ @${MV} ${WRKDIR}/Core-83eba3a/* ${WRKSRC}/src/core/
-CFLAGS+= -L${LOCALBASE}/lib
+post-patch:
+ @${REINPLACE_CMD} -e 's| -Wno-unused-but-set-variable||' \
+ ${WRKSRC}/Makefile.am
.include <bsd.port.mk>