summaryrefslogtreecommitdiff
path: root/security/truecrack/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/truecrack/Makefile')
-rw-r--r--security/truecrack/Makefile38
1 files changed, 0 insertions, 38 deletions
diff --git a/security/truecrack/Makefile b/security/truecrack/Makefile
deleted file mode 100644
index e1ea56340ed8..000000000000
--- a/security/truecrack/Makefile
+++ /dev/null
@@ -1,38 +0,0 @@
-# Created by: Ryan Steinmetz <zi@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= truecrack
-PORTVERSION= 0.1
-CATEGORIES= security
-MASTER_SITES= https://truecrack.googlecode.com/files/ \
- http://mirrors.rit.edu/zi/
-DISTNAME= ${PORTNAME}
-
-MAINTAINER= zi@FreeBSD.org
-COMMENT= Password cracker for TrueCrypt volumes
-
-LICENSE= GPLv3
-
-BROKEN= Unfetchable (google code has gone away)
-DEPRECATED= Unfetchable for more than six months (google code has gone away)
-EXPIRATION_DATE= 2017-04-30
-
-USES= gmake
-CFLAGS+= -DTC_BSD
-PLIST_FILES= bin/truecrack
-
-DICTIONARIES= dictionary_100k.txt dictionary_10k.txt dictionary.txt
-PORTDATA= ${DICTIONARIES}
-
-post-patch:
- @${REINPLACE_CMD} -e 's/CFLAGS =/CFLAGS +=/g' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's/return ;/return 0;/g' ${WRKSRC}/Main/Utils.c
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/truecrack ${STAGEDIR}${PREFIX}/bin
-.for dict in ${DICTIONARIES}
- @${MKDIR} ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/${dict} ${STAGEDIR}${DATADIR}
-.endfor
-
-.include <bsd.port.mk>