summaryrefslogtreecommitdiff
path: root/security/skipfish/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/skipfish/Makefile')
-rw-r--r--security/skipfish/Makefile45
1 files changed, 0 insertions, 45 deletions
diff --git a/security/skipfish/Makefile b/security/skipfish/Makefile
deleted file mode 100644
index 65e91d0549a9..000000000000
--- a/security/skipfish/Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
-# Created by: Ryan Steinmetz <rpsfa@rit.edu>
-# $FreeBSD$
-
-PORTNAME= skipfish
-PORTVERSION= 2.10b
-PORTREVISION= 5
-CATEGORIES= security www
-MASTER_SITES= GOOGLE_CODE
-
-MAINTAINER= zi@FreeBSD.org
-COMMENT= Fully automated, active web application security reconnaissance tool
-
-LICENSE= APACHE20
-LICENSE_FILE= ${WRKSRC}/COPYING
-
-BROKEN= Unfetchable (google code has gone away)
-DEPRECATED= Unfetchable for more than six months (google code has gone away)
-EXPIRATION_DATE= 2017-04-30
-
-LIB_DEPENDS= libidn.so:dns/libidn \
- libpcre.so:devel/pcre
-
-USES= gmake tar:tgz ssl
-SUB_FILES= pkg-message
-
-OPTIONS_DEFINE= DOCS
-
-PORTDOCS= README COPYING ChangeLog
-
-post-patch:
- @${REINPLACE_CMD} -e 's:"skipfish.wl":"${DATADIR}/dictionaries/complete.wl":' \
- -e 's:"assets":"${DATADIR}/assets":' ${WRKSRC}/src/config.h
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/skipfish ${STAGEDIR}${PREFIX}/bin/skipfish
- ${INSTALL_SCRIPT} ${WRKSRC}/tools/sfscandiff ${STAGEDIR}${PREFIX}/bin/sfscandiff
- ${INSTALL_MAN} ${WRKSRC}/doc/skipfish.1 ${STAGEDIR}${PREFIX}/man/man1
- (cd ${WRKSRC}/assets/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/assets/)
- (cd ${WRKSRC}/dictionaries/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/dictionaries/)
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
-. for doc in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
-. endfor
-
-.include <bsd.port.mk>