summaryrefslogtreecommitdiff
path: root/science/pnetcdf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/pnetcdf/Makefile')
-rw-r--r--science/pnetcdf/Makefile34
1 files changed, 16 insertions, 18 deletions
diff --git a/science/pnetcdf/Makefile b/science/pnetcdf/Makefile
index 4769406580a7..97821533219e 100644
--- a/science/pnetcdf/Makefile
+++ b/science/pnetcdf/Makefile
@@ -6,24 +6,26 @@
#
PORTNAME= pnetcdf
-PORTVERSION= 1.2.0
-PORTREVISION= 1
+PORTVERSION= 1.3.0
CATEGORIES= science parallel
-MASTER_SITES= http://ftp.mcs.anl.gov/pub/parallel-netcdf/
+MASTER_SITES= http://ftp.mcs.anl.gov/pub/parallel-netcdf/ \
+ LOCAL/sunpoet
DISTNAME= parallel-netcdf-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= A library providing high-performance I/O
-OPTIONS= OPENMPI "Use openmpi instead of mpich2" off
+OPTIONS_DEFINE= DOCS OPENMPI
+OPENMPI_DESC= Use openmpi instead of mpich2
CONFLICTS= hdf-4.*
+CFLAGS+= -fPIC -DPIC
+CONFIGURE_ENV= M4FLAGS=""
+GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_FORTRAN= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= M4FLAGS=""
MAN1= ncmpidiff.1 ncmpidump.1 ncmpigen.1
MAN3= pnetcdf.3
@@ -32,11 +34,9 @@ PLIST_FILES= bin/ncmpidiff bin/ncmpidump bin/ncmpigen bin/ncvalid \
include/pnetcdf.h include/pnetcdf.inc include/pnetcdf.mod \
lib/libpnetcdf.a
-CFLAGS+= -fPIC -DPIC
-
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_OPENMPI)
+.if ${PORT_OPTIONS:MOPENMPI}
BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/lib/libmpi.so:${PORTSDIR}/net/openmpi
CONFIGURE_ARGS+=--with-mpi=${LOCALBASE}/mpi/openmpi
@@ -48,13 +48,11 @@ CONFIGURE_ARGS+=--with-mpi=${LOCALBASE}
post-install:
.for file in ncmpidiff ncmpidump ncmpigen ncvalid
- @${STRIP_CMD} ${PREFIX}/bin/${file}
-.endfor
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ ${STRIP_CMD} ${PREFIX}/bin/${file}
.endfor
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>