summaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-socketio-client/Makefile23
-rw-r--r--net/py-socketio-client/distinfo2
-rw-r--r--net/py-socketio-client/pkg-descr4
4 files changed, 30 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 3e7ee43f2806..942607619aec 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -976,6 +976,7 @@
SUBDIR += py-simplesoap
SUBDIR += py-smbpasswd
SUBDIR += py-soappy
+ SUBDIR += py-socketio-client
SUBDIR += py-speedtest-cli
SUBDIR += py-suds
SUBDIR += py-terminado
diff --git a/net/py-socketio-client/Makefile b/net/py-socketio-client/Makefile
new file mode 100644
index 000000000000..5a3143e57bf6
--- /dev/null
+++ b/net/py-socketio-client/Makefile
@@ -0,0 +1,23 @@
+# Created by: Massimiliano Stucchi <mstucchi@ripe.net>
+# $FreeBSD$
+
+PORTNAME= socketio-client
+PORTVERSION= 0.6.5
+CATEGORIES= net devel python
+MASTER_SITES= CHEESESHOP/source/s/socketIO-client/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= socketIO_client-${PORTVERSION}
+
+MAINTAINER= mstucchi@ripe.net
+COMMENT= Socket.io client library for Python
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>0:${PORTSDIR}/www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}websocket-client>0:${PORTSDIR}/www/py-websocket-client
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/net/py-socketio-client/distinfo b/net/py-socketio-client/distinfo
new file mode 100644
index 000000000000..2ff149be4ccb
--- /dev/null
+++ b/net/py-socketio-client/distinfo
@@ -0,0 +1,2 @@
+SHA256 (socketIO_client-0.6.5.tar.gz) = 843f271074e6d2b1302ab873d2dfb37e647aea03c75d542fdd0f47b9d81085bc
+SIZE (socketIO_client-0.6.5.tar.gz) = 18387
diff --git a/net/py-socketio-client/pkg-descr b/net/py-socketio-client/pkg-descr
new file mode 100644
index 000000000000..a254a06ca6dd
--- /dev/null
+++ b/net/py-socketio-client/pkg-descr
@@ -0,0 +1,4 @@
+Socket.io client library for Python. You can use it to write test code for
+your socket.io server.
+
+WWW: https://github.com/invisibleroads/socketIO-client