summaryrefslogtreecommitdiff
path: root/net/qt4-network/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/qt4-network/Makefile')
-rw-r--r--net/qt4-network/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/net/qt4-network/Makefile b/net/qt4-network/Makefile
index baf7bb802238..083e3bad88f9 100644
--- a/net/qt4-network/Makefile
+++ b/net/qt4-network/Makefile
@@ -7,13 +7,15 @@
#
PORTNAME= network
-PORTVERSION= ${QT4_VERSION}
+DISTVERSION= ${QT4_VERSION}
CATEGORIES?= net ipv6
PKGNAMEPREFIX= qt4-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt network library
+RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+
USE_QT_VER= 4
QT_COMPONENTS= qmake_build moc_build rcc_build corelib
QT_NONSTANDARD= yes
@@ -60,5 +62,7 @@ post-configure:
-E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
-E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
${WRKSRC}/lib/pkgconfig/QtNetwork.pc
+ ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ ${WRKSRC}/src/network/ssl/qsslsocket_openssl.cpp
.include <bsd.port.mk>