summaryrefslogtreecommitdiff
path: root/net-im/tox/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/tox/Makefile')
-rw-r--r--net-im/tox/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/net-im/tox/Makefile b/net-im/tox/Makefile
index 64b897d3e967..84fd830ef5c3 100644
--- a/net-im/tox/Makefile
+++ b/net-im/tox/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= toxcore
-PORTVERSION= 0.2.8
-PORTREVISION= 1
+PORTVERSION= 0.2.9
DISTVERSIONPREFIX= v
PORTEPOCH= 1
CATEGORIES= net-im net-p2p
@@ -13,7 +12,8 @@ COMMENT= ProjectTox-Core library, a decentralized and secure messenger
LICENSE= GPLv3
-BUILD_DEPENDS= checkmk:devel/check
+BUILD_DEPENDS= checkmk:devel/check \
+ gtest:sysutils/coreutils
LIB_DEPENDS= libvpx.so:multimedia/libvpx \
libmsgpackc.so:devel/msgpack \
libsndfile.so:audio/libsndfile \
@@ -33,14 +33,15 @@ USES= cmake compiler:c11 libtool pathfix pkgconfig
USE_LDCONFIG= yes
PLIST_SUB= VER=${PORTVERSION:C/0.//}.0 SO=2
-OPTIONS_DEFINE= DAEMON
+OPTIONS_DEFINE= DAEMON TEST
OPTIONS_SUB= yes
DAEMON_DESC= Bootstrap daemon
DAEMON_CMAKE_ON= -DBOOTSTRAP_DAEMON=on
DAEMON_LIB_DEPENDS= libconfig.so:devel/libconfig
-TEST_TARGET= test
+TEST_CMAKE_ON= -DAUTOTEST=on
+TEST_TARGET= test
.include <bsd.port.options.mk>
@@ -56,7 +57,6 @@ PKGMESSAGE= ${PKGDIR}/pkg-message.daemon
post-install:
.if ${PORT_OPTIONS:MDAEMON}
- ${INSTALL_PROGRAM} ${WRKSRC}/tox-bootstrapd ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/other/bootstrap_daemon/tox-bootstrapd.conf \
${STAGEDIR}${PREFIX}/etc/tox-bootstrapd.conf.sample
${MKDIR} ${STAGEDIR}${KEYS_DIR}