summaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1-qt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/gstreamer1-qt/Makefile')
-rw-r--r--multimedia/gstreamer1-qt/Makefile32
1 files changed, 7 insertions, 25 deletions
diff --git a/multimedia/gstreamer1-qt/Makefile b/multimedia/gstreamer1-qt/Makefile
index b6651ed92f81..16b17a3343bf 100644
--- a/multimedia/gstreamer1-qt/Makefile
+++ b/multimedia/gstreamer1-qt/Makefile
@@ -2,10 +2,10 @@
PORTNAME= gstreamer1
PORTVERSION= 1.2.0
-PORTREVISION= 18
+PORTREVISION= 19
CATEGORIES= multimedia
MASTER_SITES= http://gstreamer.freedesktop.org/src/qt-gstreamer/
-PKGNAMESUFFIX= -${FLAVOR}
+PKGNAMESUFFIX= -qt5
DISTNAME= qt-gstreamer-${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
@@ -14,37 +14,19 @@ COMMENT= Qt ${FLAVOR:C/qt//} bindings for GStreamer 1.x multimedia library
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libgstreamer-1.0.so:multimedia/gstreamer1
-FLAVORS= qt5 qt4
-FLAVOR?= ${FLAVORS:[1]}
-
CONFLICTS_INSTALL= gstreamer${PKGNAMESUFFIX}-*
-USES= bison cmake gl gnome pathfix pkgconfig tar:xz
+USES= bison cmake compiler:c++11-lang gl gnome pathfix pkgconfig qt:5 tar:xz
USE_GSTREAMER1= yes
-
USE_GL= gl
USE_GNOME= glib20
+USE_QT= buildtools_build qmake_build core declarative gui network opengl \
+ testlib widgets
USE_LDCONFIG= yes
CMAKE_OFF= USE_GST_PLUGIN_DIR USE_QT_PLUGIN_DIR
-CMAKE_ARGS= -DQT_VERSION=${FLAVOR:C/qt//}
-
-. if ${FLAVOR} == qt4
-DEPRECATED= Qt4 has been EOL since december 2015
-EXPIRATION_DATE=2019-03-15
-USES+= qt:4
-USE_QT= corelib gui opengl declarative script \
- qmake_build moc_build rcc_build uic_build qtestlib_build
-PLIST_SUB= QT4_ONLY="" QT5_ONLY="@comment "
-. else
-USES+= compiler:c++11-lang qt:5
-USE_QT= buildtools_build qmake_build core declarative gui network opengl \
- testlib widgets
-QTVER_SUFFIX= 5
-PLIST_SUB= QT4_ONLY="@comment " QT5_ONLY=""
-. endif
+CMAKE_ARGS= -DQT_VERSION=5
-PLIST_SUB+= SHLIB_VER="${PORTVERSION}" \
- QTVER_SUFFIX="${QTVER_SUFFIX}"
+PLIST_SUB= SHLIB_VER="${PORTVERSION}"
.include <bsd.port.mk>