summaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile3
-rw-r--r--misc/lile/Makefile36
-rw-r--r--misc/lile/distinfo3
-rw-r--r--misc/lile/files/patch-aa90
-rw-r--r--misc/lile/pkg-descr5
-rw-r--r--misc/muuz/Makefile30
-rw-r--r--misc/muuz/distinfo3
-rw-r--r--misc/muuz/files/patch-ac10
-rw-r--r--misc/muuz/files/patch-ad19
-rw-r--r--misc/muuz/files/patch-ae11
-rw-r--r--misc/muuz/files/patch-af11
-rw-r--r--misc/muuz/files/patch-ag11
-rw-r--r--misc/muuz/files/patch-ah10
-rw-r--r--misc/muuz/pkg-descr7
-rw-r--r--misc/muuz/pkg-plist8
-rw-r--r--misc/xdf/Makefile36
-rw-r--r--misc/xdf/distinfo3
-rw-r--r--misc/xdf/files/patch-Makefile31
-rw-r--r--misc/xdf/files/patch-xdf.H21
-rw-r--r--misc/xdf/files/patch-xdf.cc85
-rw-r--r--misc/xdf/pkg-descr8
21 files changed, 0 insertions, 441 deletions
diff --git a/misc/Makefile b/misc/Makefile
index bd24b004faef..d5b8c4f5cb5b 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -297,7 +297,6 @@
SUBDIR += libpri-bristuff
SUBDIR += libutf
SUBDIR += lifelines
- SUBDIR += lile
SUBDIR += lingoteach
SUBDIR += linm
SUBDIR += localedata
@@ -320,7 +319,6 @@
SUBDIR += mmv
SUBDIR += mshell
SUBDIR += mtx
- SUBDIR += muuz
SUBDIR += nagios-base-logos
SUBDIR += najitool
SUBDIR += newer
@@ -479,7 +477,6 @@
SUBDIR += xbiso
SUBDIR += xd
SUBDIR += xdelta
- SUBDIR += xdf
SUBDIR += xenmenu
SUBDIR += xfce4-appfinder
SUBDIR += xfce4-artwork
diff --git a/misc/lile/Makefile b/misc/lile/Makefile
deleted file mode 100644
index 9a4840a01f27..000000000000
--- a/misc/lile/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-# New ports collection makefile for: ile
-# Date created: 25 Jun 1997
-# Whom: jmz
-#
-# $FreeBSD$
-#
-
-PORTNAME= ile
-PORTVERSION= 2.0
-PORTREVISION= 1
-CATEGORIES= misc
-MASTER_SITES= ftp://ftp.inria.fr/archives/system/user/
-DISTNAME= lile-2.0
-EXTRACT_SUFX= .tar.z
-
-MAINTAINER= jmz@FreeBSD.org
-COMMENT= An Input Line Editor that wraps itself around programs
-
-DEPRECATED= Broken on all supported versions of FreeBSD
-EXPIRATION_DATE=2007-03-10
-
-MAN1= ile.1
-PLIST_FILES= bin/ile
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
-do-configure:
- @(cd ${WRKSRC}; ${MV} Makefile Makefile.old; \
- ${SED} -e s:/usr/local:${PREFIX}: <Makefile.old > Makefile; \
- ${ECHO_CMD} all: ile >> Makefile; ${ECHO_CMD} CC=cc ${CFLAGS} >> Makefile)
-
-.include <bsd.port.post.mk>
diff --git a/misc/lile/distinfo b/misc/lile/distinfo
deleted file mode 100644
index 0bf8b99ccff4..000000000000
--- a/misc/lile/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (lile-2.0.tar.z) = 70b3565053e31910abec207b3731a60a
-SHA256 (lile-2.0.tar.z) = bcedb5665920e6b57d2c6db91ab27d0c5101519c37aecdb3ff098ee995bd4ad6
-SIZE (lile-2.0.tar.z) = 22901
diff --git a/misc/lile/files/patch-aa b/misc/lile/files/patch-aa
deleted file mode 100644
index 4ad606455871..000000000000
--- a/misc/lile/files/patch-aa
+++ /dev/null
@@ -1,90 +0,0 @@
---- ile.c.orig Tue Jun 8 20:12:33 1993
-+++ ile.c Sun Nov 3 15:10:18 2002
-@@ -47,11 +47,12 @@
- #include <string.h>
- #include <strings.h>
- #include <pwd.h>
-+#include <sys/types.h>
- #include <utmp.h>
- #include <errno.h>
- #include <sys/ioctl.h>
- #include <sys/types.h>
--#include <sys/dir.h>
-+#include <sys/dirent.h>
- #include <sys/file.h>
- #include <sys/time.h>
- #include <sys/wait.h>
-@@ -63,7 +64,6 @@
- /* Definitions of system stuff. */
- extern int errno;
-
--long lseek();
- char *malloc();
- char *realloc();
- time_t time();
-@@ -113,7 +113,7 @@
- struct ltchars tty_ltchars;
- struct winsize tty_winsize;
- int expect_exception, ignorestop, new_prompt, output_complete;
--int childpid;
-+pid_t childpid;
- int tty_ldisc;
- int tty_mode;
-
-@@ -267,44 +267,46 @@
- did, i.e., suspend, abort, exit with the proper status etc.
- */
- void handle_child() {
-- union wait status;
-+ int status;
-
- if (wait3(&status, WUNTRACED, NULL) != childpid) {
- fprintf(stderr, "ile: notified by unknown process\r\n");
-+ /* note the change so that we don't die after select */
-+ expect_exception = TRUE;
- return;
- }
-
- if (WIFSTOPPED(status)) {
- /* ignore stop signals that we forwarded to the child */
-- if (status.w_stopsig == SIGSTOP && ignorestop) {
-+ if (WSTOPSIG(status) == SIGSTOP && ignorestop) {
- ignorestop = FALSE;
- return;
- }
-
- #ifdef DEBUG
-- fprintf(stderr, "child stopped by signal %d\r\n", status.w_stopsig);
-+ fprintf(stderr, "child stopped by signal %d\r\n", WSTOPSIG(status));
- #endif
- /* stop ourselves */
-- handle_stop(status.w_stopsig);
-+ handle_stop(WSTOPSIG(status));
- }
- else if (WIFSIGNALED(status)) {
- #ifdef DEBUG
-- fprintf(stderr, "child killed by signal %d\r\n", status.w_termsig);
-+ fprintf(stderr, "child killed by signal %d\r\n", WTERMSIG(status));
- #endif
- clean_up();
-
-- if (status.w_coredump) {
-+ if (WCOREDUMP(status)) {
- chdir ("/"); /* prevent own core dump */
- }
-- (void) signal (status.w_termsig, SIG_DFL);
-- kill (getpid(), status.w_termsig);
-+ (void) signal (WTERMSIG(status), SIG_DFL);
-+ kill (getpid(), WTERMSIG(status));
- }
- else {
- #ifdef DEBUG
-- fprintf(stderr, "child exited with %d\r\n", status.w_retcode);
-+ fprintf(stderr, "child exited with %d\r\n", WEXITSTATUS(status));
- #endif
- clean_up();
-- exit (status.w_retcode);
-+ exit (WEXITSTATUS(status));
- }
- }
-
diff --git a/misc/lile/pkg-descr b/misc/lile/pkg-descr
deleted file mode 100644
index aa130d298914..000000000000
--- a/misc/lile/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-The ile program can be run as a simple shell around any program.
-It gives any program an input line editing and a history mechanism. It
-can also be run around your favourite shell. When run around the shell
-ile records the input to interactive programs launched from the
-shell as well as the commands to the shell in its history buffer.
diff --git a/misc/muuz/Makefile b/misc/muuz/Makefile
deleted file mode 100644
index 7dcdeddd6a08..000000000000
--- a/misc/muuz/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-# Ports collection makefile for: muuz
-# Date created: 21 March 2000
-# Whom: kline@thought.org
-#
-# $FreeBSD$
-#
-
-PORTNAME= muuz
-PORTVERSION= 0.27.2
-CATEGORIES= misc
-MASTER_SITES= http://muuz.deadbbs.com/FreeBSD/muuz/
-
-MAINTAINER= kline@thought.org
-COMMENT= X11 and sound tool that promotes relaxation, meditation, fun, more
-
-LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
-
-DEPRECATED= Broken on all supported versions of FreeBSD
-EXPIRATION_DATE=2007-03-10
-
-USE_IMAKE= yes
-MAN1= muuz.1
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/misc/muuz/distinfo b/misc/muuz/distinfo
deleted file mode 100644
index f55d3e864566..000000000000
--- a/misc/muuz/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (muuz-0.27.2.tar.gz) = 9ea52f17f310988e012fbd29e5304c7f
-SHA256 (muuz-0.27.2.tar.gz) = b7cf8263a299623c8fb33fb286d1f4cf864b0ea5d68b4d8bed9792253390416f
-SIZE (muuz-0.27.2.tar.gz) = 118356
diff --git a/misc/muuz/files/patch-ac b/misc/muuz/files/patch-ac
deleted file mode 100644
index a21ad6bc9516..000000000000
--- a/misc/muuz/files/patch-ac
+++ /dev/null
@@ -1,10 +0,0 @@
---- Imakefile.orig Sat May 20 10:55:46 2000
-+++ Imakefile Sun May 21 19:01:32 2000
-@@ -53,6 +53,7 @@
- @grep -v "^#" helpOverview.h > ./helpOverview.text
- @grep -v "^#" acknowledgement.h > ./acknowledgement.text
- @grep -v "^#" aboutMuuz.h > ./aboutMuuz.text
-+ @mkdir $(PROJECTROOT)/share/muuz
- @cp -pf helpUserPrep.text $(PROJECTROOT)/share/muuz/helpUserPrep.text
- @cp -pf helpPrep.text $(PROJECTROOT)/share/muuz/helpPrep.text
- @cp -pf helpOverview.text $(PROJECTROOT)/share/muuz/helpOverview.text
diff --git a/misc/muuz/files/patch-ad b/misc/muuz/files/patch-ad
deleted file mode 100644
index 81a70714b241..000000000000
--- a/misc/muuz/files/patch-ad
+++ /dev/null
@@ -1,19 +0,0 @@
---- main.c.orig Fri May 19 12:57:58 2000
-+++ main.c Sat Sep 7 17:04:30 2002
-@@ -80,7 +80,7 @@
- */
-
- /* HERE MAIN XXX */
--void
-+int
- main(int argc, char *argv[])
- {
- int ch, perr = 0;
-@@ -532,6 +532,7 @@
- }
-
- }
-+void
- usage(char *progname)
- {
- fprintf(stderr, "Usage: %s: [-hV]\n", progname);
diff --git a/misc/muuz/files/patch-ae b/misc/muuz/files/patch-ae
deleted file mode 100644
index fbce8254ece1..000000000000
--- a/misc/muuz/files/patch-ae
+++ /dev/null
@@ -1,11 +0,0 @@
---- mixerControls.c.orig Sat Sep 7 16:58:58 2002
-+++ mixerControls.c Sat Sep 7 16:59:43 2002
-@@ -11,7 +11,7 @@
- #include "mixerControls.h"
- #include "muuztypes.h"
- #ifdef __FreeBSD__
--#include <machine/soundcard.h>
-+#include <sys/soundcard.h>
- #endif /* __FreeBSD__ */
- #include "copyright.h"
- #include "errMessage.h"
diff --git a/misc/muuz/files/patch-af b/misc/muuz/files/patch-af
deleted file mode 100644
index b46ff79b6340..000000000000
--- a/misc/muuz/files/patch-af
+++ /dev/null
@@ -1,11 +0,0 @@
---- mixerControls.h.orig Sat Sep 7 16:59:02 2002
-+++ mixerControls.h Sat Sep 7 16:59:49 2002
-@@ -8,7 +8,7 @@
- #include "muuz.h"
- #include "muuztypes.h"
- #ifdef __FreeBSD__
--#include <machine/soundcard.h>
-+#include <sys/soundcard.h>
- #endif /* __FreeBSD__ */
-
-
diff --git a/misc/muuz/files/patch-ag b/misc/muuz/files/patch-ag
deleted file mode 100644
index 252a4dbc6e1d..000000000000
--- a/misc/muuz/files/patch-ag
+++ /dev/null
@@ -1,11 +0,0 @@
---- muuzbeats.c.orig Sat Sep 7 16:59:09 2002
-+++ muuzbeats.c Sat Sep 7 16:59:14 2002
-@@ -8,7 +8,7 @@
- #include <sys/stat.h>
- #include <sys/types.h>
- #include <sys/ioctl.h>
--#include <machine/soundcard.h>
-+#include <sys/soundcard.h>
- #include <errno.h>
- #include <math.h>
- }
diff --git a/misc/muuz/files/patch-ah b/misc/muuz/files/patch-ah
deleted file mode 100644
index b6eb6dc02e8a..000000000000
--- a/misc/muuz/files/patch-ah
+++ /dev/null
@@ -1,10 +0,0 @@
---- version.c.orig Sat Sep 7 17:12:08 2002
-+++ version.c Sat Sep 7 17:12:19 2002
-@@ -2,6 +2,7 @@
- * $Id: version.c,v 1.2 2000/05/19 19:53:32 kline Exp kline $
- */
- #include <stdio.h>
-+#include <stdlib.h>
-
- #define VERSION "0.27.2"
- void
diff --git a/misc/muuz/pkg-descr b/misc/muuz/pkg-descr
deleted file mode 100644
index 091947d3ee59..000000000000
--- a/misc/muuz/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-Muuz is a computer-only version of the kinds of dedicated processor/controller
-mind-machine devices that are made up of small discrete boxes containing
-a dedicated controller along with (usually) eye-glass frames studded
-with LED's and a pair of earphones.
-
-This program uses X11 and a soundboard to promotes relaxation, teach
-meditation, or simply for fun auditory and visual experiences. fun, and more.
diff --git a/misc/muuz/pkg-plist b/misc/muuz/pkg-plist
deleted file mode 100644
index 33da7b7e2119..000000000000
--- a/misc/muuz/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-bin/muuz
-bin/muuzbeats
-share/muuz/aboutMuuz.text
-share/muuz/acknowledgement.text
-share/muuz/helpOverview.text
-share/muuz/helpPrep.text
-share/muuz/helpUserPrep.text
-@dirrm share/muuz
diff --git a/misc/xdf/Makefile b/misc/xdf/Makefile
deleted file mode 100644
index 1b99e6280294..000000000000
--- a/misc/xdf/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-# New ports collection makefile for: xdf
-# Date created: 9 November 2002
-# Whom: David Vidal-Rodriguez
-#
-# $FreeBSD$
-#
-
-PORTNAME= xdf
-PORTVERSION= 1.3
-PORTREVISION= 1
-CATEGORIES= misc
-MASTER_SITES= http://home.in.tum.de/~vidalrod/ports/
-
-MAINTAINER= vidalrod@in.tum.de
-COMMENT= A graphical disk space viewer for X
-
-LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview
-
-DEPRECATED= Broken on all supported versions of FreeBSD
-EXPIRATION_DATE=2007-03-10
-
-PLIST_FILES= bin/xdf
-USE_XLIB= yes
-USE_X_PREFIX= yes
-USE_GMAKE= yes
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502000
-BROKEN= "Does not compile"
-.endif
-
-post-install:
- ${STRIP_CMD} ${PREFIX}/bin/xdf
-
-.include <bsd.port.post.mk>
diff --git a/misc/xdf/distinfo b/misc/xdf/distinfo
deleted file mode 100644
index 90b3ab44ba0d..000000000000
--- a/misc/xdf/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (xdf-1.3.tar.gz) = 14cb702a28058c9e25c7daf34a36a09c
-SHA256 (xdf-1.3.tar.gz) = 5a9538b7b2f0393217c1f29a712bd0273f817d79c73ce6391b4841e1d95f2548
-SIZE (xdf-1.3.tar.gz) = 16628
diff --git a/misc/xdf/files/patch-Makefile b/misc/xdf/files/patch-Makefile
deleted file mode 100644
index 090309cc12e3..000000000000
--- a/misc/xdf/files/patch-Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
---- Makefile.orig Wed Nov 13 14:06:28 2002
-+++ Makefile Wed Jul 9 17:04:06 2003
-@@ -7,9 +7,7 @@
- # on Linux systems "make ; make install" (run as superuser) should do everything
- #
-
--
--CCFLAGS = -m486 -O2
--CPPFLAGS += $(CCFLAGS) -I /usr/openwin/include -I/usr/lib/g++-include -DMAIN
-+CPPFLAGS += $(CCFLAGS) -I/usr/include -I/usr/local/include -I/usr/X11R6/include -I/usr/lib/g++-include -DMAIN
- LDFLAGS += -L /usr/openwin/lib -L /usr/X11R6/lib
- LDLIBS += -lxview -lX11 -lolgx
-
-@@ -17,7 +15,7 @@
-
- PROGRAM = xdf
- SOURCES.cc = xdf.cc
--INSTALLPATH = /usr/local/bin
-+INSTALLPATH = /usr/X11R6/bin
- SOURCES.h =
- SOURCES.c =
- SOURCES.G =
-@@ -110,7 +108,7 @@
- install:
- cp $(PROGRAM) $(INSTALLPATH)
- cd $(INSTALLPATH)
-- chown root.bin $(PROGRAM)
-+ chown root:bin $(PROGRAM)
- chmod 755 $(PROGRAM)
-
- run:
diff --git a/misc/xdf/files/patch-xdf.H b/misc/xdf/files/patch-xdf.H
deleted file mode 100644
index da0f9f5f9445..000000000000
--- a/misc/xdf/files/patch-xdf.H
+++ /dev/null
@@ -1,21 +0,0 @@
---- xdf.H Mon Dec 22 00:10:05 1997
-+++ ../xdf/xdf.H Fri Nov 8 21:17:34 2002
-@@ -51,14 +51,14 @@
-
- /*{{{ Variables */
- char* prgname;
--FILE* fstab;
--FILE* mtab;
--struct mntent* table;
-+struct fstab* fstab;
-+struct statfs* mtab;
-+struct statfs* table;
- struct statfs stat_buffer;
- int mountpoints;
- Partition* par_table[50];
- struct itimerval timer;
--
-+int mntcount;
-
- #ifdef NO_ISO9660
- int no_iso9660 = TRUE;
diff --git a/misc/xdf/files/patch-xdf.cc b/misc/xdf/files/patch-xdf.cc
deleted file mode 100644
index 7e0e39d99e65..000000000000
--- a/misc/xdf/files/patch-xdf.cc
+++ /dev/null
@@ -1,85 +0,0 @@
---- xdf.cc.orig Thu Nov 14 00:06:28 2002
-+++ xdf.cc Fri Jan 17 00:56:31 2003
-@@ -18,18 +18,18 @@
- #include <stdio.h>
- #include <iostream.h>
- #include <strstream.h>
--#include <syscall.h>
-+#include <sys/syscall.h>
- #include <sys/param.h>
- #include <sys/types.h>
--#include <sys/vfs.h>
-+// #include <sys/vfs.h>
- #include <unistd.h>
- #include <ctype.h>
- #include <pwd.h>
- #include <stdlib.h>
- #include <assert.h>
--#include <mntent.h>
-+//#include <mntent.h>
- #include <sys/mount.h>
--#include <linux/fs.h>
-+#include <fstab.h>
-
- #include "config.H"
- #include "xdf.H"
-@@ -74,17 +74,22 @@
- /*{{{ Get Information and create Panel */
- int row = 0;
-
-- fstab = setmntent( "/etc/fstab", "r");
-+ if (! setfsent()) {
-+ perror("Couldn't open /etc/fstab!\n");
-+ return 255;
-+ }
-+
-
- mountpoints=0;
-- while ( table = getmntent( fstab ) ) {
-- if ( strcmp( "swap", table->mnt_dir) && strcmp( "/proc", table->mnt_dir)
-- && ( strcmp( "nfs", table->mnt_type ) || ( ! no_nfs ) )
-- && ( strcmp( "iso9660", table->mnt_type ) || ( ! no_iso9660 ) )
-+ fstab = getfsent();
-+ while ( fstab ) {
-+ if ( strcmp( "swap", fstab->fs_file) && strcmp( "/proc", fstab->fs_file)
-+ && ( strcmp( "nfs", fstab->fs_vfstype ) || ( ! no_nfs ) )
-+ && ( strcmp( "cd9660", fstab->fs_vfstype ) || ( ! no_iso9660 ) )
- ){
- par_table[mountpoints] = new Partition;
-- par_table[mountpoints]->name = new char[ strlen(table->mnt_dir) + 1 ];
-- strcpy(par_table[mountpoints]->name, table->mnt_dir);
-+ par_table[mountpoints]->name = new char[ strlen(fstab->fs_file) + 1 ];
-+ strcpy(par_table[mountpoints]->name, fstab->fs_file);
- statfs(par_table[mountpoints]->name, &stat_buffer);
- par_table[mountpoints]->last_max_value =
- par_table[mountpoints]->max_value = ((double)stat_buffer.f_blocks * (double)stat_buffer.f_bsize) / (double) 1024;
-@@ -97,8 +102,9 @@
- par_table[mountpoints]->last_value = -1;
- mountpoints++;
- }
-+ fstab = getfsent();
- }
-- endmntent( fstab );
-+ endfsent();
-
- /*{{{ Title strings */
-
-@@ -230,13 +236,13 @@
- par_table[i]->status = TRUE;
- }
-
-- mtab = setmntent( "/etc/mtab", "r");
-- while ( table = getmntent( mtab ) ){
-- for ( int i = 0 ; i < mountpoints ; ++i ){
-- if ( !strcmp(par_table[i]->name, table->mnt_dir) ) par_table[i]->status = FALSE;
-+ mntcount = getmntinfo(&mtab, 0);
-+ for (int i = 0; i < mntcount; i++) {
-+ for (int j = 0; j < mountpoints; j++) {
-+ table = &mtab[i];
-+ if (! strcmp(par_table[j]->name, table->f_mntonname)) par_table[j]->status = FALSE;
- }
- }
-- endmntent( mtab );
-
- for ( int i = 0 ; i < mountpoints ; ++i ){
- if ( par_table[i]->status == FALSE && par_table[i]->last_status == TRUE) {
diff --git a/misc/xdf/pkg-descr b/misc/xdf/pkg-descr
deleted file mode 100644
index 3251f046d8a8..000000000000
--- a/misc/xdf/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-This is a port of xdf, a rather old program which shows
-the usage of mounted filesystems. It makes use of a graphical
-bar to show the percentage of use space, and values are displayed
-in human-readable form (K, M, G, T,...)
-See xdf -? for help.
-
-- David Vidal-Rodriguez
-vidalrod@in.tum.de