summaryrefslogtreecommitdiff
path: root/misc/randomx/files/patch-CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'misc/randomx/files/patch-CMakeLists.txt')
-rw-r--r--misc/randomx/files/patch-CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/misc/randomx/files/patch-CMakeLists.txt b/misc/randomx/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..956b88a592d2
--- /dev/null
+++ b/misc/randomx/files/patch-CMakeLists.txt
@@ -0,0 +1,17 @@
+--- CMakeLists.txt.orig 2023-09-04 17:31:42 UTC
++++ CMakeLists.txt
+@@ -192,6 +192,8 @@ install(TARGETS randomx
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+
++if (${BUILD_TESTING})
++
+ add_executable(randomx-tests
+ src/tests/tests.cpp)
+ target_link_libraries(randomx-tests
+@@ -234,3 +236,5 @@ if(NOT HAVE_CXX_ATOMICS)
+ endif()
+ set_property(TARGET randomx-benchmark PROPERTY POSITION_INDEPENDENT_CODE ON)
+ set_property(TARGET randomx-benchmark PROPERTY CXX_STANDARD 11)
++
++endif()